Problems with publishing


(Patrick Judge) #1

I have a websitebuilt with RW8. I recently built a blog page (called Blog-TEST) with poster and published to the host server. It is built using the Foundry theme. It is actaully on the server with the other website pages. However, the page has not published i.e. when you check judgephotocrafts.com (http://judgephotocrafts.com/) on google or safari, the website does not include the new blog page. ( In RW8 it has the show in navigation ticked and the Draft unchecked like all other pages that pblish) Before I get ontyo the host company there are a few issues that I’m not sure of:

I have changed the PHP to version 7.2 in the server,. The min requirements is 7.0.

I have RW 8

There are two stacks installed, one with rapidweaver version 3.6 and a Scribe stack.

The blog post is created in the foundry theme with foundry containers and with the inclusion of a Poster Stack.

Am I missing something. Any advise would be much appreciated.


(Mathew Mitchell) #2

What is the address of the blog page? (Or what should it be?)

You have a blog page: https://www.judgephotocrafts.com/blog/

… but it’s clearly not made with Poster.

Your home page looks like it could have been created with Poster. So I’m not sure if that’s the relevant page.


(Jan Fuellemann) #3

A question for @instacks :slight_smile:


(Patrick Judge) #4

Mathew,
That blog page is made with the RW KIKI theme. As all the other pages in the website are based on the Foundry theme, I want to replace the existing Blog page with a new one using Poster & Foundry. The name of the new page is Blog-TEST. It works fine on simulation and in preview, publised to the server fine but does not end up on the browser bar when you open judgephotocrafts.com in google etc.


(David) #5

It might be helpful to know the exact URL of your new blog page.


(Mathew Mitchell) #6

This URL has nothing:
https://www.judgephotocrafts.com/BLOG-test

My guess is this isn’t because of not publishing but that you have given us the incorrect link. Remember there are 2 different things:

  • name of the page (which is for the menu navigation only)
  • name of published page: which is what the URL goes to

Look at General Settings (RIGHT side of page) and folder name: that’s the name of your published page


(Jannis from inStacks Software) #7

Hi Patrick,

This is the URL: https://www.judgephotocrafts.com/Blog-Test/index.php

A server side PHP error is most probably thrown. Please get the php error log and send it to me: https://instacks.com/contact/

If you aren’t able to find it, please zip your project and send it to me.

Thanks, Jannis


(Jannis from inStacks Software) #8

And: you are most probably not able to see the page in the navigation, because you did not republish all files.

Please first republish all files and recheck.


(Patrick Judge) #9

Jannis,
I see a PHP file missing. I send you a copy to info@instacks.com. Thanks.


(Jannis from inStacks Software) #10

It turned out that a standard PHP module was missing in the Server PHP installation.


(Patrick Judge) #11

I made progress on the issue. I got the Host company to install the iconv module in the server as advised by Jannis. I t worked. I intended to test out the Blog-Test page and then to remove the old blog page and change the Blog-Test to Blog. I have done this and the new blog page is working fine. There is no reference to Blog-Test anywhere on the server (if you search cPanel for Blog-Test, it dosesent exist) - expected as it has been removed. When you go into judgephotocrafts.com the navigation bar does nt include Blog-Test as expected and the Blog tab is the blog as designed using Poster stack with the foundry theme as expected. However, once you click on any navigation item e.g. LIPF, the Blog-Test reappears on the navigation bar.

I had a look at the index.html file (under any of the folders) and it contains Blog-Test). Is this something to do with the issue as I’ve spent days trying to get sorted.


(Jannis from inStacks Software) #12

Did you republish your whole project? All pages?


(Patrick Judge) #13

Yes. I’ll try that again. I couldn’t republish all from rapidweaver as for some reason it stalls (I think its nothing to do with RW but space on the Host server - thats what they tell me), so I published the whole website to a local file and used Transmit by Panic to upload each folder onto the server. It worked fine.


(Patrick Judge) #14

It will be later on today when I get a chabnce to re-publish as unforunetly `i’m at work today.


(Patrick Judge) #15

Apparently the Blog-Test code is present with in website. I would have imagined that when you remove a pge the reference to that page is removed on a re-publish. The Host company have spotted this as the reason for the problem. Their answer is:

Blog-Test code is present under the website code. For example Blog-Test code is present under file /home/judgepho/public_html/about/index.html

[cpanel01.host.ie:/home/judgepho/public_html/about]
cat index.html |grep Blog-TEST

                            <ul><li><a href="../" rel="" class="nav_item">Home</a></li><li><a href="../recent images/" rel="" class="nav_item">Recent Images</a></li><li><a href="../blog/" rel="" class="nav_item">Blog</a></li><li><a href="../Blog-Test/" rel="" class="nav_item">Blog-TEST</a></li><li class="Selected"><a href="./" rel="" class="nav_item nav_active">About</a></li><li><a href="../contact me/" rel="" class="nav_item">Contact me</a></li><li><a href="../LIPF/" rel="" class="nav_item">LIPF</a></li><li><a href="../gallery/" rel="" class="nav_item parent">Gallery</a><ul><li><a href="../gallery/hungary/" rel="" class="nav_item">Hungary</a></li><li><a href="../gallery/iceland/" rel="" class="nav_item">Iceland</a></li><li><a href="../gallery/norway/" rel="" class="nav_item">Norway</a></li><li><a href="../gallery/scotland/" rel="" class="nav_item">Scotland</a></li><li><a href="../gallery/flowers/" rel="" class="nav_item">Flowers & Nature</a></li><li><a href="../gallery/macro/" rel="" class="nav_item">Macro</a></li><li><a href="../gallery/wildlife/" rel="" class="nav_item">Wildlife</a></li><li><a href="../gallery/sunrise/" rel="" class="nav_item">Sunrises / Sunsets</a></li><li><a href="../gallery/ireland/" rel="" class="nav_item">Ireland</a></li></ul></li></ul>

[cpanel01.host.ie:/home/judgepho/public_html/about]


(Jannis from inStacks Software) #16

RW Never deletes old pages from your server.


(Patrick Judge) #17

Thanks Jannis.
I finally have it all working. I republised the site to a local folder on the mac dektop. I then replaced each folder in the server with the one from the local folder. I checked the index.hml folders and the reference to Blog-Test was gone. Thanks for your help and patience. It looks fine now. The server has no folder other than those from the local folder.


(Patrick Mooney) #18

Use the Armadillo (v2) blog stack from NimbleHost works great with Foundry and standard Rapidweaver themes and with the newer PHP and easily linked to Disqus if you want people to be able to comment.


(Patrick Judge) #19

Thanks very much. I’ll keep Nimblehost’s Armadillo on my radar. I have already bought Poster and have it working now but it’s always better to keep options open.