Brand new copy of RW, brand new computer, no work

Brand new Mac Mini M1, brand new copy of Rapidweaver 8, running macOS 12.0.1.

When I start Rapidweaver up, create a new project, select a page type, and pick a theme it crashes. Crash report says ‘Crashing on exception: launch path not accessible’. It will also crash if I select the Simulate option.

Rebooted, same issue. Uninstalled and reinstalled. Same issue. Tried downloading an older version. Same issue. Went and downloaded version 8.7 to see if a non-native M1 compiling might work. Same issue.

This is a brand new install. While I have used Rapidweaver before, that was like 3 versions ago and I’ve got no add-on’s installed on this computer. This is as virgin an install as you’re going to find and it crashes every time.

I noticed someone else had a similar issue and tried their fix (removing the Rapidweaver folder from the Containers directory). Same issue.

I emailed Rapidweaver support 2 or 3 days ago, but haven’t heard back yet. Just trying to figure out what else I can do before I decide this isn’t going to work.

@dan ?

Hi @peeceejunior.

So sorry to hear you’re having issues, this certainly shouldn’t be happening, we have lots of users running RapidWeaver on an M1, including us!

Please make sure you’re running RapidWeaver 8.9.3 - you can download it from here:

Can you post the crash report?

Without it, it’s hard to track down what might be causing the issue.

Don’t worry though, we’ll get to the bottom of this and get you up and running!

Many Thanks,
Dan

I downloaded 8.9.3 this morning and the problem appears to be fixed. Not sure what the difference was, but it’s working now.

I will email you the crash report I took down a couple of days ago just in case you guys want to see what the issue was.

Thanks!