[VIDEO] RW keeps crashing right after opening… Help?

Rapidweaver Auto Crash??

You will get a reply more quickly if you supply more information, or better yet a link to a published site which probably isn’t available here. But always, which platform, which stacks/theme?
Almost always, without further information, one suggestion is create a new project and see if it still happens.
Then report back…

1 Like

Thanks Chuck. The video I supplied should address your response.

Sorry to hear you’re having issues!

Follow this guide here to get back up and running:

@dan, thanks for your reply.

Unfortunately, I can not get past Step 1: Launch RapidWeaver without Addons.

RW attempts to launch and immediately closes while holding down the option key.

Yesterday I sent an email to support@realmacsoftware.com with a separate video showing the issue I am having.

Hopefully, I will get a helpful reply soon. Thanks again.

Hi, where is the RW app located? Is it in the Applications folder of your computer? And are you using an M1 computer or an Intel one?

Hello, RW is in the Application folder. I am using and Intel Mac. Thanks.

Then please download the app again and try to open this new downloaded version:

Thanks for the weblink.

I downloaded it, extracted it and placed the application in the applications folder. Just like a I did multiple times yesterday.

I was hoping that I would get different results from the link above versus the file downloaded from https://www.realmacsoftware.com/ or the link provided in the email when I retrieved my License.

Unfortunately, it launched and crashed like in video of this original post.

However I did get a crash report. Please let me know if that information is helpful.

Screen Shot 2022-01-04 at 11.25.18 AM

Thanks again.

I have one comment about the diagnose steps.
It says to be sure to use the latest version yet it never says to make sure you are using the compatible version for the Mac Operating System in use.
Some folks don’t update their OS regularly.

You may also want to start in safe mode to check that it isn’t a conflict with another Mac App. A stretch, but perhaps it isn’t RW.

BTW, the Mac OS is so stable, many folks go a long time without restarting their Macs. I’m used to restarting my Mac after most major Application installs and updates. It’s the equivalent of turning your computer off & back on again when something didn’t work …

1 Like

@dan, I’ve tried everything everyone has suggested with no working results.

What is the standard email support turnaround time regard the email I sent yesterday?

Also, for the first time I got the error message: The application “Rapidweaver 8” can’t be opened. I never seen this error prior to now.

Screen Shot 2022-01-04 at 3.36.37 PM

Thanks again.

Hey, did you try using something to maintain your mac, like Onyx? I often had to run it to fix different problems, like apps that do not open and so on.
Also, when installing again, I try to be sure of cancelling everything from that app, searching in “application support”, “preferences” and things like that…then I re install or run Onyx before…just my 2 cents

1 Like

Sounds like it’s a system issue or something interfering with RapidWeaver…

What version of macOS are you running?

1 Like

MacOs 10.13.6
iMac (27-inch, Mid 2011)
2.7 GHz Intel Core i5

It seems it’s good for version.

What if you tried an older version of RW? Maybe v8.8.x

1 Like

This happened to me back in the day when I was trying to “hide” all the icons in RW toolbar in order to gain some more space on a small screen. RW started just crashing, I reinstalled, tried safe mode - nada. How I solved it is; I used an app called AppCleaner by FreeMacSoft and removed RW along with all associated files with it (Application Support, Containers, etc.)

I then reinstalled RW and it worked. Of course the downside to it is, if you haven’t backed up your stacks, you’ll have to deal with that. Plus you’ll have to dig up your serials for RW, Stacks, etc. etc.

Of course you can backup your stacks (just search for how to right here on the forum).

Hope this helps.


BTDT. The worst part was re-entering the serial numbers as I had “upgraded” RW so had to start with the earliest serial number if I remember correctly and not just the most recent. Made me hate the process more than necessary.

Installed RW 8.6.2. Problem solved. Thanks everyone.

1 Like