Broken Stacks Since Stacks Update


(Mark Medford) #1

I recently updated to the latest version of Stacks, I have the RW update but haven’t run it yet. I’m a bit gun shy. All of my stacks are the most recent versions. My theme is Hive by Elixir. I had a page on my site that contained the Owl slider by Doobox. I merely changed one picture, synced the page via Transmit, and the stack would not display. I then swapped it out for Orbit by Elixir to see if that would work. It did not display correctly (the images were slacked vertically). I also noticed that a pictured that animated in via Animagic had disappeared. Also my Timeline Thing stack by RW central no longer worked. So basically, the page was “broken”, all by just changing an image. Does anyone have any idea what could be causing this? I’m nervous because I have other updates to make on other sites. I ended up recreating that page with nothing animated and no sliders just get it up there. Thank you!


(Matthew Long) #2

I have also noted some issues since upgrading from Stacks 3.0.5 to 3.1.0.

I use the Doobox stack Agent-X, and it no longer works with the latest version of Stacks 3 (the stack previews OK, but nothing appears when published). If I look at the published site in my web browser’s error console I see the message “ReferenceError: Can’t find variable: jQuery”. This error only appears in Stacks 3.1.0, not in the previous version. If I downgrade Stacks back to 3.0.5 everything works again.


(mark hunter) #3

Have you tried: File > Mark All Pages & Resources as Changed, then: File > Republish All Files ?

If that isn’t fixing it where are the images in the Resources area of Rapidweaver, inside the stack, or Warehoused on your site?

A link to the site showing the problem would also help.

Reads

Mark


(Jannis from inStacks Software) #4

Please always check if there are also new stack element updates available.


(Doobox Software) #5

Hi guys,

It’s a bank holiday weekend here, so I will be pursuing your support requests on Tuesday morning.
But…

I just quickly republished the demo pages of
Owl Stack : https://www.doobox.co.uk/stacks_store/givaways/demos/agentx.html
&
Agent-X Stack : https://www.doobox.co.uk/stacks_store/demos/owl.html

The are now published with RW7 and Stacks version 3.1
They both function properly as expected.

@mdlong Your page has some element that is breaking the javascript, but it does not appear to be the Agent-X stack. Once the javascript is broken, this has a knock on effect to other elements that use javascript in the page.
@Mark419 I suspect the same holds true for your page, though I have not had an opportunity to look at your page yet.

This could be caused by another stack that needs to be updated. Or it could be a publishing issue.
If you have been publishing with a third party FTP application, can I suggest you try using RW to publish. There are issues that do arrise using third party FTP applications that are not correctly setup for the needs of your server. We see this all the time. It gives no indication that anything went wrong during the FTP publish, but in fact there are many files that do not get published to the server.


(Mary Delton) #6

I just upgraded to Stacks 3.1 and now my ZIP LIST stack no longer works. My other stack by Sey Design (ZIP BAR) still works fine but I really need the ZIP LIST to work. How do I downgrade to Stacks 3.05? I went to yourhead website and clicked on the download Stacks 3 and what downloaded was ver 2.1.3. Confused here.

Mary


(Mary Delton) #7

I was able to go back to an earlier version of my website that hadn’t been updated to Stacks 3.1. Of course I had to redo all the updates I had made after I upgraded to Stacks 3.1.
I also upgraded to RW 7 but when I did, of course I also updated to Stacks 3.1 and now I can’t use RW7.
Crying in NY

Mary


(Matthew Long) #8

After lots of discussion with Gary at Doobox (very helpful thank you), I was able to solve my issues with the Agent-X stack. It seems that when I upgraded from Stacks 3.0.5 to 3.1.0, the latest version of JQuery file was not uploaded to the server. When I looked on the server at rw_common->plugins->stacks I saw the file ‘jquery-2.1.4.min’, but I should have seen ‘jquery-2.2.2.min.js’. When I uploaded this later version via FTP it all started working again.


(Mark Medford) #9

Anything on the Owl stack? Thank you


(Doobox Software) #10

There is nothing to be updated in the Owl stack. The issue you are seeing is likely to do with the way you are altering / uploading files with Transmit. If you upload with RW 6, 7, or 7.1 it will work as expected.

You could of course upload with Transmit, but you need to be setup absolutely correctly for your particular server.
And remember just because the way you used Transmit yesterday worked flawlessly for you, does not mean that holds true today.
Transmit may or may not have changed things in recent updates to the application.
You host may have changed subtle requirements on your server.


(Doobox Software) #11

@mdlong if you look in the exported site locally where ever you exported it to, you will see that Stacks 3.1 does indeed generate the jQuery file with the correct name and extension. The .js extension has been stripped during the upload with Transmit.


(Doobox Software) #12

Get back into using RW’s built in publishing guys, it’s never been better :slight_smile:


(Bruce Bressack) #13

Hi Gary - my client uses Aabacco (aka YAHOO) to host his website. I’ve never been able to publish directly from Rapidweaver but had good results using CyberDuck until his host implemented TLS 1.2 on January 4th. Cyberduck still enabled me to connect to their server but I was unable to successfully replace/overwrite files. His host provided instructions for FTP using FileZilla which enabled me to publish, however, the OWL slideshows aren’t visible on his website any longer. It appears that all files are being published so one would assume everything would work properly but unfortunately it isn’t.

I’m hoping, with your advice, that I would be able to publish directly from rapidweaver to Yahoo which would save me some time. Any advice? Do you know if rapidweaver is TLS 1.2 compliant?

Thanks,
Bruce


(Bruce Bressack) #14

Hi Gary - I figured it out and am now able to publish to yahoo directly through rapidweaver resulting in the OWL slide shows now working as intended.

Bruce