Cannot access the Inspector in RW 6.3.4


(Jeffrey Shaw) #1

Quite suddenly, RW is unusable as I cannot see the Inspector. I have tried clicking the button at top right and selecting View > Page Inspector. Nothing. Restarted the app; restarted the computer; reinstalled the app; deleted pref files (or at least the ones in ~/Library/Preferences that start com.realmacsoftware.rapidweaver… This is either something deadly serious or incredibly stupid, but either way I am stumped and unable to use Rapidweaver. Help!!


(Rob D) #2

That is strange. Which button did you try to click? It should be the white one that says “Info”. Did you try keyboard command: “Command+Shift+I”?


(Jeffrey Shaw) #3

I have been clicking ‘Info’, ‘Inspector’, the Page Inspector item in the View menu, cmd-shift-i … nada!


(Rob D) #4

I would open a ticket at RMS…


(Jeffrey Shaw) #5

Thanks - I did but RW tech support proved unable to help beyond repeatedly suggesting that I delete the app and download a fresh copy - which I had done many times, to no avail. I finally solved it by recreating a fresh set of preference files (installing RW6 into a new user account) and copying them to my user folder.

In doing this I discovered that RW6 does not put its preference files in ~/Library/Preferences but in ~/Library/Containers/com.realmacsoftware.rapidweaver6. That was where I assume some file had gone rogue and fouled up the RW Inspector. I think it should be clear to users where to look if they ever need to trash preference files in order to reset a misbehaving application.


(Isaiah Carew) #6

The Containers folder is the standard location for any Mac App Store sandboxed application.


(Jeffrey Shaw) #7

Common knowledge for developers, but evidently not so much for the rest of us!


(Isaiah Carew) #8

Yes, apple now considers everything in the Library folder (also now hidden). Kind of a bummer if you ask me

but the point is that RW is following the rules of the MAS since Mac OS X 10.7 when sandboxing was introduced. And while I don’t like this particular rule very much myself, I’d rather RW follow the rules than not. :stuck_out_tongue:

Isaiah


(ZsXdCf12) #9

I have the same problem. Need help to get this resolved


(Jeffrey Shaw) #10

It happened to me a second time and I dealt with it by deleting the Container.plist file - but you then have to re-register the software and the Stacks plugin. It would be far preferable if it didn’t happen at all!


(Jannis from inStacks Software) #11

Try to change the screen resolution:

E.g. If you have a Retina display, try to pump it up to the largest screen resolution available. Try to open the inspector, and if it does not show up, restart Rapidweaver (maybe two to three times).

That always helps me.


(Jeffrey Shaw) #12

It is not that sort of issue. It is a bug - the inspector not opening, not merely being hidden or otherwise invisible.


(Jannis from inStacks Software) #13

Well, still what I have written does help.

Give it a try. Select a high screen resolution, enlarge RW also, and see what happens…


Recent projects when in osx menu but not in rw6 menu
(Brian LaPan) #14

Simplified instructions that usually do the trick:

  • Open Terminal.app
  • Copy/paste:

defaults delete com.realmacsoftware.rapidweaver6 “NSSplitView Subview Frames Main Document SplitView”

  • Press Enter
  • Restart RapidWeaver.

It may also do good to restart your computer.


Can't find Lost Sidebar
Page Inspector not working
Nothing's changed with 6.3.5
Inspector window does not open
(Brendan Cush) #15

My project has suddenly developed this today. It isn’t a big or complex project, has a lot of content, but it has now ground to a halt without any obvious reason why. Tried the above suggestions but I’m not prepared to delete and re-install without knowing that this will fix this critical issue. Done this before and lost several days trying to re-install everything (I’m not a developer). I’ve closed and re-opened RW many times and with no projects and variations of projects. Same result. I’ve got all the latest versions of everything and running a dual-screen setup - with everything at maximum settings.
I’ve now opened a blank project and added a few pages to that and the Inspector does work for that. I’m going to try and transfer all the stacks and content over to that to see if I can get the project going again.


(Brendan Cush) #16

Hi. What does this command do? Sorry for the lack of good knowledge!


(Jeffrey Shaw) #17

One thing that did fix it for me (as described above) is to delete Containers.plist in ~/Library/Containers/com.realmacsoftware.rapidweaver6, You will have to re-register RW and some other items such as Stacks. It’s inconvenient but not as bad as what you’ve just proposed doing.


(Brendan Cush) #18

The Terminal command works - many thanks


(Brian) #19

I had this same issue. It was extremely frustrating. The terminal command worked to resolve it but I feel like its something RW should have done officially. e.g Notifying customers of this problem.


(Nik Fletcher) #20

It’s due to a quirk in the OS X Autolayout feature. We’re investigating (and have reported the issue to Apple)!