Cannot install stack 4 plugin into Rapidweaver

Hi, can any one help me?
I am new to rapidweaver. My version is 8.6.2
I was trying to install stacks 4 plugin … but failed completely.
There is message “Stacks.rapidweaverplugin” cant’be opened because Apple cannot check it for malicious software.

So what shoud I do next to solve this problem ?

Where did you get the stacks plugin from?

Sounds like you maybe have gotten an older version(before they were notarized) and are installing on Catalina.

Try grabbing a new copy here(free download button):

http://www.yourhead.com/stacks/

1 Like

Thanks for replying.
The one that I used was from the link that your provided.
The version is Stacks_4.0.4_4813.

That’s a unique thing then. I don’t know of anyone else having problems installing the latest version of stacks.

  • What version of macOS are you using?
  • Are you using any outside “malware”, virus or firewall apps?

Dear Doug,

  • I am using 10.15.6
  • I am using INTEGO Software.
    • NetBarrier 10.9.11
    • VirusBarrier 10.9.26

My bet would be the INTEGO Software, might be blocking the install, but that’s just a guess.

I’m not familiar with those apps so I can’t say that’s the problem for sure.

Do you have a screenshot of the message that pops up?

Also make sure RapidWeaver is running out of the applications folder.

I’d probably contact YourHead support(the maker of stacks).
https://yourhead.zendesk.com/hc/en-us/requests/new

Give them all the information and attach a screenshot, give them a link to this post as well. @isaiah is good about getting back to you.

Doug:
Thanks for your advice.CleanShot-Stacks

  1. Attached file is the screenshot.
  2. My rapidweaver is now running under applications folder. I will move it out somewhere.
  3. Had already submitted problem to yourhead before posting to forum.
    Until now, they haven’t got back to me. not good though.

@isaiah can you shed light on this?

something doesn’t jibe here. the version listed is definitely signed and notarized – otherwise we all would be having the same issue and my support inbox would be overrun with this problem (it isn’t).

my bet is that we’re looking at two separate copies of Stacks – the one that is running is somehow older – and the copy that was downloaded is not currently running.

perhaps you have an old copy installed, and when you double click to install that old copy is momentarily trying to run (before even the installer gets going).

or perhaps there are multiple copies of stacks installed – an old copy that is running, and a new copy that is being updated?

my recommendation:

  1. open the RapidWeaver addons folder ( View menu > Reveal Addons Folder ),
  2. remove all copies of the Stacks.rapidweaverplugin,
  3. Quit RapidWeaver,
  4. download a fresh copy of Stacks from http://yourhead.com/stacks
  5. unzip and double click to install

if this doesn’t work, then there is something truly amis with RapidWeaver or macOS on this machine.

Isaiah

1 Like

Isaiah
I just tried what you suggested.

Got the same results. Any suggestions?

Dear Isaiah :
I also uninstalled rapidweaver and then re-install it again. Got the same results. And I noticed that every plugins in the attached files yieded the same results.

Dear Isaiah and others:
Problem is now solved. I suspected that the problem came from MacOS itself.
So I did clean install for MacOS Catalina. Then installed rapidweaver with stacks plugin. Finally it works. Thanks for your support.

1 Like

I just found the way to solve this problem without clean installation of MacOS.
This is to temporary disable security and privacy control on MacOS.

  1. open terminal
  2. Issue following command. sudo spctl --master-disable
  3. Install stack plugin
  4. Issue following command. sudo spctl --master-enable

that’s kind of cutting the Gordian knot – a bit like solving the problem of a sticky deadbolt on your front door by removing all the doors to your entire house.

:open_mouth:

this command disables gatekeeper completely on your machine – which is probably fine for the tech-savvy and developers among us that have lots of backups and don’t mind living dangerously – but maybe a bit drastic for most RW users.

i guess so long as you make sure to enable it after, then it’s probably pretty harmless, though.

but i’d probably recommend trying to get to the bottom why your machine/RW/Stacks is behaving so differently than most others. it’s bound to affect more than just this single app.

3 Likes

Isaiah:
Thanks for your advice. I agree.
Seems like some other 3rd party software such as intego bundle suite produced same" …malicious …" as well when I tried to uninstall it (that’s when i want to rule out the effect of anti-virus software).
Due to my limited knowledge , do you have any suggestion where I should start ?