Stacks 4 Installation issue

I am embarrassed to ask this for fear of looking really stupid, but I recently purchased Stacks 4, downloaded the zip file, but cannot find the actual plugin that I need to click on to install it.

This is the contents of the folder:

The item called “stacks” is a Unix executable file, not the plugin.

I am sure I am missing something obvious.

I think that you just open the download file. Then you have to close and restart Rapidweaver.

It looks like you have opened up the plugin package.

Did you download the plugin twice. The name of the folder you have opened appears to have a “2” at the end of the name?

The file that you need to run should be called “stacks.RapidWeaver.plugin”.

Exactly! But I can’t find that file. Even when I search the unzipped folder for “stacks.RapidWeaver.plugin” it turns up empty. No, I didn’t download the zip file twice, that is the name of the zip file that was downloaded. The actual zip file name, which was downloaded directly from the YourHead site is “”. Of course, no response from submitting a support ticket yet, otherwise I wouldn’t be bothering you folks.

I just re-download stacks 4 from this link: Downloading Stacks (same link that’s on Stacks 4 page.

This is what I get:

I then Double-click on it to unzip and this is what I get:

If I right-click it and select show package content
I get what you have:
RapidWeaver plugins are a special folder called a package (as are RW projects and add on stacks). macOS determines these special folders and determines how to open them.

Your Mac does not realize that these folders are to be opened by RW.

I would try to reinstall RapidWeaver.

How will reinstalling Rapidweaver affect the contents of the zip file? When I opened Rapidweaver, it said there was a new version available and I updated the program so I guess it was reinstalled at that time. But if you downloaded the zip file and got the same results, then is the stack missing? Since it is serial numbered, could you just send me the plugin file?

It’s not the content of the zip file that’s wrong.

Look at my screenshot (2nd) of the file that came out of the zip file. It’s a RapidWeaver plugin, not just a folder.

I had to right-click the plugin and select “show package content” to see what’s inside.

RapidWeaver tells macOS that any folder that ends with the extension rapidweaverplugin is not a normal folder but a package. So hopefully reinstalling RW will get that association back.

Reinstalling RapidWeaver will tell MacOS that RapidWeaver is the program to associate the Rapidweaver.plugin packages with. Updates do not have this effect on MacOS, only complete installations/re-installations.

1 Like

OK, I think I understand now. Sorry for being so slow. I tried dragging the app out of my applications folder and then downloaded a fresh version from Realmac, but it’s the same. Is there an uninstaller that I need to use or a preference file that I need to delete? Is there a written procedure to uninstall and do a fresh install?

OK, I have the problem solved. Boy, I really feel dumb! So Doug was right when he noted that the extracted folder has a number 2 after it. Mac OS put that there because my stacks 3 plugin had exactly the same name as the stacks 4 plugin. So when I deleted the stacks 3 plugin and then removed the space and numeral two from the end of the folder name… VOILA! it turned itself indo a Rapidweaver stack and the program accepted it.

If it wasn’t for the excellent help that you guys give on this forum, it would likely take days or maybe weeks to resolve it through YouHead support.

Thanks so much!!!


Interesting, as the “2” should have in that case be added in the following way:

Stacks 2.rapidweaverplugin

Maybe something got confused :grinning_face_with_smiling_eyes:

1 Like

I encourage you not to feel that way. The dumbest questions are the ones never asked.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.