Cannot upload updated files


(Barry Riley) #1

it is a couple of months since i last updated any of my websites which use RW5.4.1. today when i tried to upload a amended [page i received a selection of messages. See below.

FTP Publishing error
Failed to create remote directory “Sitemap.xml”

RWSitemap Plugin
Couldn’t save sitemap page

Couldn’t sign into FTP Server
Couldn’t connect to server

RWFTP Connection error
Could not connect to remote host.

Couldn’t.t save the sitemap page
The RWSiteMapPlugin plugin had a problem saving the document, and RapidWeaver may now be unstable or even crash. Please contact the vendor of the plugin for assistance, and give them the following details:

You must purchase a registration code to save SiteMap pages
Please visit http://www.loghound.com to purchase a code

======
As i also have a copy of RW6 (although i prefer 5) i tried this as well. Have tried different RW sitemaps and non at all. All with no success. Have reloaded files and applications from Time machine but without success. Can any one please help. At wits end as just cannot understand what is happening.


(scott williams) #2

To Trouble shoot it;
First I would check that you can actually connect via FTP if you have an ftp app.
If yes, then check that the publishing settings in RW match the settings in your ftp app
if no, then the issue is most likely with your host.

Next, try to publish a single page from RW (not the sitemap page) If that works then your host and RW ftp is working.

Next, contact @isaiah at Yourhead support, I believe they are now the caretakers of the sitemap plugin


(Barry Riley) #3

Thanks for that.
Have tried Cyberduck without any success. Not tried it for ages so cannot remember how it should be but most options not available and when I go to file>Open URL nothing happens. So it looks as Ftp not working. Can you tell me what I should try next.
Barry


(scott williams) #4

if you have your ftp settings correct in cyberduck and it won’t connect then.

You can also connect via your browser… ftp://yoursite.com you should get a request for username and password.
If you can’t connect via ftp it’s a hosting (or connection) issue - I would contact your hosting company.


(Barry Riley) #5

Thanks for your help. In view of your comments I contacted 1and1 who provide my hosting. Was on the phone to them ( they phoned me) for over an hour. After various tests they provided me with a different hosting code and now all my important sites work ok. Think the problem was at their end. Thanks again.