Can't get Google Fonts to work, what are these other ways?

How do you get Google Fonts to work? I’m trying Foundry’s “Typeface” stack, that loads the fonts and assigns them to the Typeface 1,2, 3 etc menu… then you assign them to Paragraphs, but they dont work, tried loading all weights, tried different font sizes, refreshed the text with new raw text, no go no go

Tried Paragraph Pro… same thing, set it all up, and doesn’t work. The font name is a no brainer, it’s called Righteous. That’s it. There’s not a lot to get wrong. When they say Google Font Name, they mean Just the Name, Right? Not a path to some server say…

What’s the trick to get Google fonts to work, and Typeface allows for a few choices, “STANDARD FONT” and “SELF HOSTED FONT”… Is one of these “Choose font off your drive, it will travel with the page, it will be loaded, it will work”… is one of those THAT? What is Standard Font and Self Hosted font. Do they work better?

Adam is great but I decided to lean on the list to give him a break.

Not at my Rapidweaver computer right now but have you checked the Typeface videos: https://foundry.elixirgraphics.com/tutorials/#utility

You’re correct that you don’t need a specific path but you do need exact spelling/punctuation, as well as make sure that the weights are available

Edit: Actually, just checked out Righteous and it looks like it only comes in 1 weight (400/Regular). So it’s possible that you were trying to load a weight that didn’t exist, so it defaulted to something else

1 Like

no at first, and still I’m loading 400. There’s not a lot to get wrong with the name Righteous. When you select your paragraph, click, and then select the Typeface 1 that it’s assigned to, should you see it in Edit Mode, you should definitely see it in Safari Preview mode correct? This is Catalina. RW won’t run on my Mojave main Mac, I’m running it in a Virtual Machine, don’t think that should affect this process… all other downloads work, wifi is on, there’s not much to this, there’s not much I could be doing wrong… you basically name a font in one place, and select it in another place, and it’s supposed to appear, but won’t, about to try “Standard Font”, dont know what that means, assume it means “off my drive”

I wouldn’t think that Catalina would be a factor. I can’t double check settings now but in that link of videos above, there’s one specifically for Google Fonts.

I don’t think you’ll see the change in Edit mode. You should see it in the built-in preview and in Preview in Safari.

It should be as easy as you expected it. Paste the Font name in the Typeface child stack, assign to a typeface number, select which font weights to load. Then in your paragraph, change the font to that Typeface number.

Here’s a RW project that’s working here. (RW8 + Stacks 3 + Foundry needed)

You know how you can change the project wide default font for text, in the Foundry them stack that you have to drop in, clicking that allows you to change the default “Control Center” font for regular text, and one for Headers, well that feature is working, more or less, most of my text stacks have changed to the font I assigned there… a few won’t change, I tried making new text stacks for the text, no go, tried paragraphs where you can assign a typeface number, no go, so only some of my text areas are responding to the global setting. This is frustrating, for you have to be able to do stuff, rely on it, it has to be robust. My google fonts are getting loaded, when I change the global font to any of the four I’ve defined, most of my text areas change, live in Preview mode… so I know they are loading, they are just not assignable on a paragraph level, and some text areas won’t pick up the global setting. Frustrating. Paragraphs not working applies to Foundry’s paragraph, and to Paragraph Pro, also doesn’t work, it’s font at least, it’s typesetting works, adjusting line height for example, works, just not the font. Gotta be able to assign various fonts to different areas and have it work. I hope I find a paragraph that takes a font setting…a paragraph stack that is. I watched the videos, but because this is brain dead easy it was an exercise in waiting for the other shoe to drop… the voice proceeds kindly and slowly through this really easy material. Nothing new learned that isn’t obvious from the settings themselves. I’m a programmer, not a computer newbie. I get software.

Let’s start by making sure that you can load and see Google fonts on your system. Download the project I created. The header is in “Righteous” Google font. The paragraph is just the Foundry default.

Does the header display in the correct font?

Here are a few screenshots with settings, in case that helps…

Ok, I re-read your last post. If you have some paragraphs that don’t change, how are you putting the text in those text boxes? Copying and pasting it from another app?

If so, you’re probably copying and pasting formatting from it. Always paste text “as plain text” under edit menu (learn the shortcut too!).

If you want to post a link to a single page project showing the issue, I’ll have a look.

Pasting as pure text may be the trick, as the text has color and possibly other formatting already assigned to it somehow, that’s the only thing that makes sense, the text areas that are working to show the control center base paragraph font were typed straight into text stacks and didn’t have outside influence, will try paste as text… I dont have my site published yet, but maybe I’ll get that going to a test destination on my server, I think that’s what you mean Don when you say “post a link to a single page project showing the issue”.

Paste as text is crucial. If you are copy/pasting from something like MS Word then you’ll run into all sorts of problems.

I’ve actually never seen someone have so many problems (or any problems) with Foundry’s Typeface stack. It’s very powerful, but also very easy, to use. So @DLH 's suggestion is the most likely problem. But the problem definitely isn’t with Typeface stack.

1 Like

Yep, paste as plain text did the trick, now my PARAGRAPHS are responding to font changes, it was “previous formatting” that was blocking the feature from working.

RELIEF, this is an easy thing, it should be easy, it is easy, you just CANT have previous formatting hiding in the text, paste as plain text is CRUCIAL as Mathew said, I’m RELIEVED NOW, THANK YOU DON and Mathew… got it going. Phew.

Definitely worth getting an app that will auto-copy text as plain text for you. I use Paste (app store), but there are a few other good options that will allow any text to be copied/pasted as plain text only.

It’s really easy to forget (when working hard) whether you copied something as formatted text or plain text. Nice to have a little help in the form of an app. I think Paste is something like $14.99 but not positive. And it does a lot more than just paste as text. More info here:

But if all you need is paste as text (and not the other great features of Paste) then there are cheaper, and still very effective, options.

I emailed you back about this @DasGoravani — glad others also helped you out here with the formatting problem you introduced through copy and pasting formatted text. Paste as plain text in the Edit menu is a must IMHO.

Well to me, RW’s Option-Command-V paste as plain text is good enough… I don’t need clipboard history, or organization, I keep everything source nicely organized and stored, now EVERY PART of the Typeface stack is working, paragraphs, headers, default control center base choices, so I’m good to go, one thing I still wonder about is “what’s wrong with working with mainly, only, “standard fonts”, ones you load from your hard drive”… do those travel well with the project and into the real world, will they display, or do they get lost… Google fonts works, but something about having the fonts being a link to a server, I dont know… old school inner feelings tell me to have my own fonts, ahh I’m talking nonsense here… over and out, I’m good to go. Thanks for the help. REALLY appreciate it.

Now for the truly hard part which is picking good fonts. My thing, my project, my business, which it’s for, is a bit other worldly since its Astrology Software, and at that it’s from the East, Vedic Astrology Software, so I have some ground to move upon that is “other worldly”, hence why I was looking at Righteous, which is a font loved in the east. Most of my customers are from the West but they are folks who are deeply touched by the East. I want fonts that stand out as special and different, have an Other Worldly feel… but not too much. Righteous goes a bit over the top, it’s kind of bold too. Titillium Web is a good one. Using that now as base font. Have to pick a few others.

I’m REALLY SORRY that I post so much. I’m damn intrepid when it comes to solving bugs, not patient. I did think it might be formatting, and saved my source docs as pure text, copied from that, but it still didn’t work. The paste as plain text works. I’ll use it always.

Darn sorry to be a pain. Sorry. Over and out.

What I meant was to just copy a page you’re having the issue with into a blank, RW project file and save it, that we you have a simple, one page project illustrating the issue. Then you can put it on Dropbox or similar and post a link. It’s what I did with the example file I posted earlier.

With that said, yes, having a temporary site where you can upload the in-progress site will probably be helpful in the future. In a case like this, we could have looked at the link and quickly confirmed that it was text pasted with formatting that was causing the issue. It’s often a lot simpler to help when we can see a live page.

1 Like