Foundry Typeface Font Doesn't Appear After Publishing

Hi,

Hoping someone could help me…

Below is how Typeface is showing up on a page. This has never happened to me before. It would usually show the google font with the different numbers. As a result of this, I believe, after I publish, the default font appears and not the google font.

I’ve tried changing the foundry base font, but it still doesn’t work. Any ideas?

Thank so much in advance!!!

Best,
Niks

Did you restart RapidWeaver after updating to the latest version of Foundry? If not please restart RW and let us know if that resolves your problem.

Hi Adam,

I tried restarting, the typeface format returned to normal. When I “simulate” each page on RW, the fonts appear with the typeface Google font. However, even after I re-published, the published site still appears with a default font and not the google font.

Thanks again!!

You’ll need to provide us some more information then to be able to assist you.

Let us know what font specifically you’re attempting to use. Send a link to the Google font.

In addition, please provide me a ZIP file containing your project file. After creating the ZIP file, use WeTransfer or a similar service to create a download link that you can share with me. You can email that to adam at elixirgraphics dot com

Perhaps “republish all” files will help? Or, cleaning up duplicate files on the server?

Perhaps, but it would be best to get the requested information above to troubleshoot the problem.

Hi @niks

Thanks for the project file. It helped me track down your problem.

You have mistakenly typed the font name as prompt instead of Prompt

Unfortunately this is a case sensitive thing. Google tries to load a font named prompt and isn’t finding it, so it returns an error:

You’ll need to update your Typeface stack to use Prompt for the font name.

Additionally it looks like you’re also using the “Custom” font setting in the Control Center to load this font (also with the incorrect capitalization), as seen here:

You should be using Typeface here, too, and not the “Custom” option. The Custom option is depreciated and is not as good at loading fonts as Typeface is. Typeface has some tools for speeding things up a it as well.

Once you update everything to use Prompt for the font name you should see it working again A-OKAY.

4 Likes

Hi Adam,

Thank you so much for your help!! I changed it on a few pages, it works!

Best,
Niks

1 Like

Not a problem. Glad to hunt that down for you.