Can't move from RW5 to RW 6


(Carys Jackson) #1

Morning, please can someone help. I am trying to move from RW5 to RW 6 (at last). I have updated everything, but when I open RW6 and try and open my project, it’s no highlighted as selectable. I am sure I am doing something really silly, but can someone help me as its driving me potty!! Thank in advance


All content is missing, upgrading from RW5 to 6
(David) #2

Hi,

You have to update to RW 5.4.1, save your project(s), then they can be opened in RW 6. See the upgrade guide:

hope this helps.


(Carys Jackson) #3

Thanks, I have done that, but it is still not highlighted - weird


(David) #4

When you open an RW5 project in 5.4.1 try doing a ‘save as’ and naming your project “my_project_updated”, and then try opening that file in RW6 to make sure you’re opening the file that has been saved in RW5.


(Scott Steven) #5

try and drag the project onto RW 6 icon on your doc see if that forces it


(Oscar Schmid) #6

@carysjackson

I think, you look on the wrong place for your RW 5 file.

When you have found your right RW 5 file in the finder,

you can double click the icon
you can drag and drop it on the RW 6 icon
… and / or …
you can start RW 6 and open your file via menu from the right place.

There are no RW 5 projects not highlighted as selectable.
Only RW 4 projects are not selectable and cannot be opened with RW 6


(Oscar Schmid) #7

@carysjackson

Can you publish here a screenshot of your files not highlighted as selectable, please?


(Carys Jackson) #8

Thanks guys. I have tried dragging and dropping, and am about to try save as option. Here are some screen shots


(Carys Jackson) #9


(David) #10

Cary,

It seems like only one of your screenshots made it here (as far as i can see). Can you post the others, including “the screenshot of your files not highlighted as selectable”, as our very brilliant friend @Oscar suggested? thanks :slight_smile:


(Oscar Schmid) #11

The screenshot shows that you are right with RapidWeaver 5.4.1. With this version you have to save.
Then you should open the new RW5 file with RW 6.3.8. All RW 5 files are selectable in the window (files with blue icon or a preview image). Can you publish a screenshot with the same window, like image 3?

Open here …

… or here


(Oscar Schmid) #12

Thank you @thang David, thank you for the praise. I do my best.
I am very happy if someone assist who speaks English better than I. :wink:


(Carys Jackson) #13

Sorry, hope this works -

Thanks in advance


(David) #14

OK - The file list is so small it’s kind of hard to see the filenames with my old eyes, but with my magnifying glass I do see activewoman.rwsw in there. I haven’t done this operation for quite a while but just tried it and this worked:

  1. Open activewoman.rwsw in RW 5.4.1
  2. Save the file as activewoman_For_RW6.rwsw or whatever name you’d like just so you know that it’s the file you’re going to open in RW 6.
  3. Quit RW 5
  4. Launch RW 6 and open the new activewoman_For_RW6.rwsw file
    5.You will get the following message:

  1. The new RW6 file will be in the same folder right next to your activewoman_For_RW6.rwsw file and will be named activewoman_For_RW6.rw6 and that is your new RW 6 project file which you will use going forward in RW 6.
  2. Close your activewoman_For_RW6.rwsw and open the activewoman_For_RW6.rw6 in RW 6. Any changes you make in that file will be saved and you will open and use it in RW 6 going forward with that project.

If that doesn’t work i suspect you have some other issue(s) going on. If you run in to trouble perhaps try moving your file out of your Google drive shared folder and into a conventional folder and try this procedure again. I don’t know if that’s a factor as i don’t use Google Drive like that and haven’t seen mention here of anyone else placing their project file in a shared folder. That might not be an issue at all, but got me wondering…

HTH


Importing RW 5 Project into RW6 doesn't work
(David) #15

@Oscar,
IMHO, your posts are among the most helpful here in the forum. You have great patience for the beginner’s questions to the most advanced level questions, and often provide brilliant solutions to complex problems. I always enjoy reading your posts and have learned a lot from your very clear examples, explanations and instructions. I also very much admire your efforts to write in English - very brave of you, and so helpful to those of us like me who are too ignorant to understand even one word of Swiss German. I think you do very well with the English but if i can help out when the language becomes a problem I will do my best, and hopefully I won’t get it all wrong and further confuse the original poster.

Cheers,
Dave


(Oscar Schmid) #16

Load your RW 5 file from Google Drive to your computer. You are right, on Google Drive it’s not selectable. I don’t know why.
When the file is on the computer (desktop), I am sure, you can open it with RW 6.


(Robert Zemeski) #18

This fix did not work for me. I am on a MacPro running the OS X 10.11.4.
RW 6 does not recognise the file. My file reads: River Valley BC-new_For_RW6.rwsw
Maybe there is a different application suffix for the file in RW6?

There was an button “export to 6” as seen in a YouTube video = Tutorial: Upgrading from RapidWeaver 5 to RapidWeaver 6 by Ryan Smith at video mark 4:40 – https://www.youtube.com/watch?v=oNqkYkH57KI (you will have to increase you browser magnification to see it), but there is none in my version 5.4.1.


(Oscar Schmid) #19

Read here, please


(Carys Jackson) #20

Thanks guys, and sorry for the delay - manic week. I have tried save as and i have tried moving it, but it is still un selectable - very frustrating and almost going to give up and stick with 5 :frowning:


(Oscar Schmid) #21

That can not be. Something is going wrong on your computer.
Do you have the file on the computer desktop?
Then you can drag this new RW 5 file (saved with RW 5.4.1) on the icon of the RW 6 app.