Can't save RW 5.4.1 project


(Dwayne Rourke) #1

Please provide a few details in the following format so we can help you as quickly as possible!

RapidWeaver Version: 5.4.1
System Version: *10.11.3
Hardware: 13-Inch MacBook Pro 2.5 GHz Processor, 16GB Memory.

Size of project: 2.3 Gb

Issue:
I cannot save my project nor can I “save as” under a different name.

I’ve repaired permissions but the problems persists.

Expected Result:
Edit. Save. Upload.

Additional Links:


(Mathew Mitchell) #2

I have no idea what the real source of your problem is, but a project file of 2.3 Gb is a sure sign of problems at some point. Your project file seriously needs to go on a “weight watchers” program.

I have no idea what’s in the file but it seems like you either have a ton of large images, or perhaps a number of videos, or perhaps both. Whatever the case it is likely that learning how to warehouse some of those “big things” will significantly reduce your file size, make RW breath a sigh of relief, and brighten up your day. If the size is due to videos then you may want to consider warehousing via YouTube or Vimeo.


(Dwayne Rourke) #3

Thanks for your thoughts Mathew.

What, in your opinion, is an outer limit for a RW project?

I have no videos on the site except as embed code to source vids on YouTube.
All images I’ve used have been “normalized”. I thought this got me around the large photos issue. Is that correct?

For what its worth, I’ve just now managed to upload the site without it saving first. After having done that successfully, the project still will not save and close.

Ideas anyone?


(Robert Ziebol 🖖🏼) #4

What does “normalized” mean? I would be sure my images are optimized. You can optimize images for the web with apps like JPEGmini or ImageOptim. The first is obviously for jpgs, the second is for pngs.

I would also suggest to warehouse images where necessary, ESPECIALLY if you use the same image on multiple pages, this will make your site load faster.


(Dwayne Rourke) #5

I used the term “normalized” because that is what Rapidweaver uses. You find it in the drop down menu under File. Can anyone explain its function, if not to reduce file size?


(Robert Ziebol 🖖🏼) #6

Ah, did not notice it was there. No idea what that does.


(Dwayne Rourke) #7

By the way, thanks for the links.


(Mathew Mitchell) #8

@dwayner: This is weird: not videos but 2.3 Gb in size. Either you have a LOT of photos, or very big photos, or there’s something super weird going on. But right now I’m not voting for “super weird”. How many photos would you estimate you’ve used? (No need for an exact count, but if we had an idea it was 10 vs. 100 vs. 1,000 would really help.)

I always warehouse my images. But in several cases that’s not needed. And, to be fair, whether you warehouse or not you’ll always want to optimize your images first. @zeebe gave some good apps for optimizing. There are also other issues: it may be that your image dimensions are too big and really should be resized (regardless of optimization). Sometimes just changing from PNG to JPG can make a big difference.

As a rule-of-thumb it’s good to aim for images at 300k or smaller for all images. And if they can all be 200k or less that’s even better. And it’s a rule of thumb. But if you have images that are 1, 2, 5 Mb then you know something out-of-whack is going on.

Finally, I would never ever use RapidWeaver for prepping images. I have no idea what normalization does, but RW is not meant to nicely handle editing/prepping of images. But what you should use really depends on circumstances. There’s an app called EasyBatchPhoto that I use a lot. I often have final images for multimedia that are 1920x1080, but each image may be 6-10 Mb. Using EasyBatchPhoto I can easily resize, and pretty well optimize, all my photos in one go: be they 10 or 1000 images. But there are other good approaches and tools too.


(Mathew Mitchell) #9

If you don’t know what size your images are, try giving us a link to a page that has some typical photos on it. We’ll be able to suss out the size (I think).


(Dwayne Rourke) #10

Thanks Mathew.

I’ve used no more than a 100 photos but I realize I have not been exacting in checking on file size for each image. I’ll do that and get back to you.

RW says that “Image Normalization will look for large images that have been rescaled to a smaller size. It will replace very large images with a rescaled version.”

I just now tried scaling down some images, then hitting Normalize Images. The project crashed…:unamused:


(Mathew Mitchell) #11

@dwayner Well 100 photos at 5 Mb would still only be 500 Mb. Large indeed, but it doesn’t explain the 2.3 Gb. So I’m going to make some guesses: either you have a camera that creates really big JPGs and you used the originals, OR over time you’ve put several big pictures into RW but you only ended up using about 100 of them.

I have a camera that takes big JPGs that are about 23 Mb. So 100 of those would get you at about 2.3Gb. I doubt this happened to you, but it’s possible.

For many people it would be more likely that they treated RW somewhat like a word processor or PowerPoint where they drag in materials (mainly photos) but then delete several from their slides as they go through the editing process, or they just change their minds. But those old unused photos are still stored in the RW project file (at least as I understand it).

The 2.3 Gb file size on it’s own probably did not cause your problem, but it certainly doesn’t help. It may be a contributing factor.

Probably what you need now is RW project file surgery. And that’s nothing any of us should be guiding you through. I’d contact RW support directly. They’ll probably want you to get them the project file. It’s a huge file, but getting them the original is the only way they can figure things out and hopefully fix the problem.

Is it possible there’s a general bug in RW that creates your problem? Sure. But it’s not a common problem, and I’m focused on that huge file size and the consequences of that are likely contributing factors.

I have no idea how big your website it, but let me give you an example of what warehousing does. I’m currently working on a course website with lots of videos (probably 30 to 40), lots of audio files (easily 100+), and several images. I have about 40 pages total with lots of content. Project file size: 15 Mb. But that’s because I warehouse: videos to Vimeo or YouTube, audio directly FTPed to my hosting account, images directly FTPed to my hosting account or linked to via Flickr.

I’m not trying to say you should do things exactly as I have done. Many people don’t run into problems and they take different approaches. But in the long run, after you’ve sorted out this mess, it is worth your time to learn how to optimize images and how to warehouse your biggest and most important materials (likely your images).

But right now I doubt we can help you, and a deep look by real pros are needed to fix this. I doubt there’s any easy fix to your issue. Even if it got “fixed” for one time the problem would likely reappear sometime again down the road. The good news is I think the RealMac people should be able to sort this out for you but it may take a few days.


(Dwayne Rourke) #12

Thanks for the comprehensive reply Mathew. I’ve sent an email to Realmac as you suggest. Cheers.


(Dwayne Rourke) #13

Can anyone here tell we what Rapidweaver “.as” files are about?

I’ve discovered dozens of them in my RW projects. They range in size from 387 bytes to 51.1 MB. Most seem to be in the 1 to 3 MB range.

Could be a clue as to why my project file (above) is so large.

Comments welcomed.


(Nik Fletcher) #14

The .as files are simply part of the document (they’re how RapidWeaver serialises the styled text data in your project).

Unfortunately, we don’t guarantee compatibility on OS X 10.11 with RapidWeaver 5 I’m afraid. RapidWeaver 6 being a 64-bit app means it can handle larger files much more robustly (through virtue of it being able to address larger amounts of memory). Have you tried RapidWeaver 6 with this project file? If so, and are still seeing issues we’d love to see a copy of the project file (ZIP-ed, uploaded to somewhere such as Dropbox) so that we can profile how RapidWeaver performs with another large dataset.

As a follow-up: has the project file never saved with RapidWeaver 5.4.1? Which version were you using previously?

Thanks,

—Nik


(Dwayne Rourke) #15

Thanks for your suggestion Nik.

I am happy to report that opening, editing, saving and uploading the problem file numerous times with RW6 has proceeded flawlessly.

Regarding RW 5.4.1, the file would save intermitently and would sometimes upload without first being saved. I can’t remember the exact name of the RW version I used prior to 5.4.1 but it was 5 something.

Thanks again to you and the Rapidweaver team. I love working with RW!


(Dwayne Rourke) #16

FYI I have opened my RW5.4.1 project file, made changes and successfully saved and uploaded it. The file size for the project has, on its own, reduced from 2.3 gig to 848MB.


(Dwayne Rourke) #17

I am sorry to report that using RW 6 w/El Capitan I am running into the same problem again (not being able to Save OR Save As).

Last week, I followed your suggestion and submitted a zipped project file to Realmac. I have acted on the suggested fix, which was about repairing permissions, but no success.

Anybody have further suggestions?