Characters not Displaying Correctly


(Cynthia Taylor) #1

Hello,

In some of the pages I am creating with RW, some of the characters are not displaying correctly, and I don’ t know why or how to fix them. I am trying to display: I Know My ABC’s Award, but it displays as: I Know My ABC’s Award. Also, the breadcrumbs are doing the same thing on the bottom right of the page. Where it should be little right facing arrows, I’m getting some different symbols too. Does anyone know how I could fix this? I’m using the Copper Theme by SeyDesign. I’ll put a link below. Thank you!

http://educationoasis.com/new/main/printables/awards/abc-award/


(Rob D) #2

Hi, @cynthia, everything looks fine on my computer (both body and breadcrumbs). However, in breadcrumbs the apostrophe is missing. I see ABCs instead of ABC’s. Apart from the technicalities, the version in breadcrumbs is stylistically correct.
Safari 9.0.2; OS X 10.9.5


(Doug Bennett) #3

Not on my iPad iOS 9.2 safari. Looks like the ABC line is a header. H2 maybe. Not at my Mac so I’m limited in what I can do.


#4

What do you have in Preferences for Default Encoding ? I had Western (ISO Latin 1) and the ABC’s were showing as weird characters, but when I changed to Unicode (UTF-8) then it displays correctly:


(Stuart) #5

If Chrome:-

An encoding setting of Windows-1252 will produce this. You can use this handy table to troubleshoot unsolicited chars:
http://www.i18nqa.com/debug/utf8-debug.html


(Cynthia Taylor) #6

It seems like it displays differently in different browsers. Thank you for checking it for me!


(Cynthia Taylor) #7

Yes, I made the ABC line with Joe Workman’s Letter Press Stack. Thank you for checking and letting me know!


(Cynthia Taylor) #8

Unfortunately, I am not with the computer/browser I used in order to check the Default encoding of it. However, I will check it tonight as soon as I am able to. Thank you for bringing that to my attention because I wouldn’t have even thought to check that!


(Cynthia Taylor) #9

Thank you for making me aware of the chart. I’m not positive how to make the corrections though by using it, but I can try. I am a beginner for the most part, and this is pretty much Greek (or Latin) to me. I will look at it and give it a try though. Thank you so much!


(Doug Bennett) #10

Hello,
Back at my Mac and did some playing around.

Don’t have the theme your using but do have @joeworkman letterPress stack.

On your site the: [quote=“cynthia, post:1, topic:4605”]
ABC’s Award
[/quote]
appears on Safari with the default unicode set to western(ISO latin 1).
it also appears this way on my iPad (iOS 9.2) .
I did change my Safari to Unicode (UTF-8) as @britinusa outlined and it did clear up.

I do not thing you can change this on an iPad (not able to find that setting) and I think my Mac was set to the default.

I tried letter press in both foundation and the reason theme (comes with RW) and it appears to work correctly on Safari (set to both western(ISO latin 1) and Unicode (UTF-8)) and the iPad.

I have never had a problem with LetterPress (don’t know what settings you are using). But you might try changing the Theme to see if it clears up.

Anyway I don’t think you would want to rely on people changing the default settings on there browser.


(Stuart) #11

@cynthia
The chart was really provided to try to get you to see the relationship between the chars (symbols) that are appearing and what you thought should be being rendered. It won’t solve anything as such.

Doing nothing is not an option here. Anything that relies on end users doing something is doomed to failure.

I am able to reproduce this issue using Copper and Letterpress. I can get it to happen when I do the following:-
(a) Add Letterpress stack to page.
(b) Copy text from a word processor like ‘Pages’ where the word contains a symbol like " ’ " ( as opposed to a ‘straight’ apostrophe like: " ’ ".
© Preview in a browser where the character encoding is not UTF-8. Now the problem is visible.

Without knowing more about your workflow its hard to know exactly what to recommend, but try this at least:-
(a) Open the project and remove all the text from the LetterPress stack. Manually type in the text again… no pasting.
(b) Select/highlight the text and go the format menu option and ensure that ‘smart quotes’ is turned off.
© Still in the format menu choose to clear and ignore formatting.

Preview or publish… does that help?


(Cynthia Taylor) #12

You’re right. I wouldn’t want people to have to change the settings in their browser. I do want to stay with the Theme I am using though, but I’ll see if there is anything I can find for the UTF-8 settings. Thank you for your help!


(Cynthia Taylor) #13

Yes, that did seem to help! I republished the page, and it seems to be acting as expected (hoped for) in my browser now, which I usually use Google Chrome. In my browser, I am still getting the funky characters in the breadcrumbs at the bottom right of the page, which I still really don’t know how to fix that, but at least the Letterpress part looks better. I followed your instructions exactly as you said, with (a) - ©. I sincerely thank you for all the time, effort, and help you gave me. You’re amazing - I wish I had your insight! I didn’t even know about the chart, or that there are different types of apostrophies. I don’t know what the ‘smart quotes’ does, but I tried to turn it off anyway as you said. I love your statement: “Anything that relies on end users doing something is doomed to failure.” Again, Thank You So Much!


(Stuart) #14

You are welcome. It looks like you are on your way now, so well done.
If you are really stuck for how to fix the breadcrumb chars (by manually typing in the characters). Then I suppose you could use this CSS snippet to override whatever is in there just now. Paste this into the global CSS container in your project:

nav#breadcrumb ul li a:after {
        content: ' | ' !important;
}

Thank you for the kind words, they mean a lot, but I’m really not very amazing. In fact, I’m rather dull :slight_smile:


(Cynthia Taylor) #15

I may try the CSS snippet you provided if I can’t do anything else with the breadcrumbs. They look OK in some browsers, but show the funky characters in others. Anyway; Thank You again, as I’ll probably end-up trying the snippet, and for fixing the Letterpress issue! You are not dull to me; in fact, quite the opposite.