Chrome browser downloading an mp4 as a text file? Any ideas why? + audio download plugin - SOLVED ✅


(Peter Gill) #1

Hi Folks

I have some audio tracks on my website that for some reason download as .txt files on google chrome, the file is fine once the extension is renamed! It works fine in Safari. Curiously a direct link to the file works fine, its something about the attribute “download” in the code that throws it.

I have searched the web but nothing comes up. It is probably a chrome issue but I wanted to check.

I’d be happy to use a plugin for this kind if thing too if one was recommended. I want a simple way of offering visitors a way to download an audio track as well as play it live.

Thanks!


(Jan Fuellemann) #2

Hi, I think you need to adjust the .htaccess file. Depending on the type of audio tracks add something like:

instruct browser to download multimedia files

AddType application/octet-stream .mp3

Repalce the .mp3 with the filetype your files are using…


(Peter Gill) #3

Ok I’ll give that a try.

Its odd as this direct HTML works: download audio

But anything that uses the rapidweaver system to generate a link in a button or even a plain link does not work.


(David) #4

Why not use the URL option in the RW link tool and put the complete URL to the file in there.

If you actually want the file to download rather than appear in a browser player, you will have to zip the file and link to the zipped file.


(Peter Gill) #5

Thanks David,I have tried that and it doesn’t work. It does the same thing. I;ll have a think about zipping as it’s not the best solution and as i mentioned it all works fine on Safari.


(David) #6

If you’re using Stacks, there are quite a few audio stacks, some of which have a download option.

I noticed your linked file was an .m4a which is a Mac file format. It may be worth trying an mp3 for browsers other than Safari.


(Peter Gill) #7

Thanks. I will try an mp3 first to see if that solves it!


(Peter Gill) #8

Ok - converting them to mp3 files worked! Thank you.


(David) #9

Glad it worked. Maybe mark the subject ‘solved’ to help anyone else having the same problem?


(Peter Gill) #10

Sure - but I cant see how to “mark as solved”…


(David) #11

I thought there was an option for the original poster to mark a post solved. Maybe not, so I just added it to the header.


(system) #12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.