Cloudflare working but can't publish to subdomain


(Noah Palmer) #1

Per Ben’s February 14 blog post about Cloudflare, I’ve got my Little Oak domain nspalmer.com registered with a free Cloudflare account and working fine. Thanks to Ben for the heads-up.

However, I also have a subdomain (interfaith.nspalmer.com) that shows up okay, but Rapidweaver just hangs when I try to publish to it.

I tried registering the subdomain on Cloudflare, but they won’t accept it because it’s not the main domain. Is there any special trick to handling subdomains with Cloudflare and Rapidweaver?

Thanks in advance for any information.


(Doug Bennett) #2

Not sure what is hanging up.
Your subdomain seems to work ok with an HTTPS connection.
https://interfaith.nspalmer.com/
This might help:


(Noah Palmer) #3

Thank you! I’ll check it out.

I did earlier search for that topic on the Cloudflare site, but I didn’t find anything. Now at least I know what to look at.


(Noah Palmer) #4

Thanks for getting me part of the way, at least. I appreciate it.

I’ve got the subdomain set up as a CNAME record in Cloudflare’s list. The subdomain site shows up fine on the web, but Rapidweaver still can’t seem to connect to publish updated files.

I tried Rapidweaver’s Test button and it tried for a while before saying it couldn’t connect.

I went back to an older version of the subdomain site and that wouldn’t connect, either. Then I tried the login ID and password from the main domain site, which didn’t work.

I hope that someone else has run into this problem because I’m out of things to try.


(Doug Bennett) #5

Are you using an IP address or server name for ftp?


(Noah Palmer) #6

Apparently, the A record type only takes IP addresses and the CNAME type only takes domain names. I was using a server name with a CNAME type. (“IPv4” must be a new thing; the last time I was a real web developer was probably 15 years ago.)

Should I delete the CNAME record that uses the domain name, and replace it with an A record using the IPv4 address? I’ve got the IPv4 address and a different port number for SFTP.

Thanks again.


(Noah Palmer) #7

SOLUTION

The best information that I’ve been able to find is that you can’t publish from Rapidweaver to a subdomain that’s managed by Cloudflare, BUT there is a WORKAROUND.

On the Cloudflare page for your main domain, you can PAUSE Cloudflare’s management of the domain. It will continue to pass traffic to your domain but without the SSL features. You can then publish to your subdomain (I just did it). After you finish publishing, you can go back to Cloudflare and un-pause your domain.

It also looks like if your site is hosted by Little Oak (which bills itself as Rapidweaver-friendly, and I’ve found that to be true), Little Oak provides shared SSL for your domains and subdomains, so you might not even NEED to use Cloudflare. But I have not yet verified if that is true.


(Noah Palmer) #8

I chatted with Little Oak support and its shared SSL feature will not meet Google’s requirements to avoid having the sites labeled as insecure. They offer regular SSL, but you’ve still got to buy a certificate from an SSL vendor.

So if you don’t want to buy an SSL certificate (like me, you’re not really engaged in eCommerce), it looks like Cloudflare is the best choice. The drawback is that you have to pause Cloudflare’s domain management any time you want to publish to one of your subdomains. You can still publish to a top-level domain without pausing it.


(Doug Bennett) #9

Although CloudFlare works(from their server to the user), it’s not the only thing that can be done. I dumped Little Oak and switched to a hosting company that offers Let’s Encrypt certificates.

Subdomains require a particular type of certificate referred to as wildcard. Let’s Encrypt the free SSL certificates just started offering wildcards, not every hosting company that does Let’s Encrypt offers them yet.

The only reason little oak or any hosting company doesn’t offer truly free (not that shared stuff, your page runs as a subdomain of theirs) is it cuts into sales of certificates. Let’s Encrypt doesn’t cost the host a penny.


(Noah Palmer) #10

Thanks! I will check that out.


(system) #11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.