Compatibility Check, Can't get any version to work

Please comment on system type, I have a MacBookPro, about 6 mos. old, 32 GB RAM, plenty of disc space, First installed latest RW, Stacks, Foundry, and got no boundaries, or borders, to the objects (Stacks) that I would place…unable to work, seeing only text and dots, Tried going back to RW 7 and Stacks 3, still the same look, it’s as if my MAC is incompatible, hence the title, checking to see if anyone has a new MacBookPro and is doing OK, Mojave 10.14.6, the latest… not on Catalina. Can’t Weave at all. Really bummed. Adam from Foundry helped me out, it’s not his bug. When I open a Stacks page, the very first thing I see is like 3 rows of periods, dots, and it says drop stacks here, but it’s not got a boundary, a border, to it, any stack I drag over, just adds more dots, no borders…you can’t work this way…sent picture to “the available” Adam at Elixir, he could see the boundaries when he opened my sent project file. Showed a pic of it in another thread. It had borders to the stacks…workable. I dont get borders. I only get dots. Does anybody have an idea what this could be…about my Mac…I dont have a lot of software installed. To my knowledge I dont have anything that should be messing this up. I’ve tried the latest RW and Stacks and Foundry, and I’ve tried going back a version. Same thing. I see there is a thread “Is RapidWeaver compatible with Mojave”, well isn’t that the DoMInant OS being used these days? That’s what I have. About to try the latest everything on Catalina Virtual Machine that I have, to see if it works. Waiting on support from RW and YourHead already. Eager, so posting here again.

UPDATE: I just installed EVERYTHING fresh onto a Catalina virtual machine I have running in Fusion, and RIGHT AWAY the look is different when I select a stacks page. I get a box, with a border, and I assume I will get that with other stacks I drag over. So I am working in Catalina, NOT working in Mojave, which I find very odd, but whatever. This is a drag, as virtual machines are slow, but at least I can work. Can’t upgrade my main system to Catalina as I need iWeb to access my old websites resources. Anyways, I can work, so the heat is off, the pressure is off. I’m MEGA surprised it doesn’t work for me in Mojave. I notice that the background of the work area is now respecting Dark Mode, whereas in Mojave where I got the bug it was light mode.

Isn’t this the same Problem as this post:

It’s definitely something to do with your setup not Mojave in general. There’s a lot of folks still using Mojave and stacks with foundry who aren’t experiencing this issue.

I’d definitely follow Adam’s (@Elixir) advice and contact Yourhead support (@isaiah) and/or RealMac support (@tpbradley).

1 Like

I’m happily running the latest versions of everything in Catalina in a virtual machine.

Just wanted to say the heat is off, I’m happy and impressed with what I’ve been able to do so far. I’m on my way.

I think it’s up to you about fixing Mojave’s problem. If you’re like me and think you’re going to be running Mojave for a while because of compatibility issues then it’s worth spending the time to fix. If you think you are going to upgrade to Catalina soon it might not be worth the effort.

@isaiah or @tpbradley might have input but My gut says it’s something with an internal “Aqua” macOS setting. Something like accessibility or contrast or one of the many internal “NS” (NextStep) parameters that can be set with the terminal.

It could be limited to a RapidWeaver or stacks parameter or corruption that’s happened.

If you want to spend the time on it something you might want to try. Make sure you have a good backup before starting.

  1. Turn off dark mode
  2. If you’re not noticing problems on other apps then I’d next try to completely uninstall RapidWeaver and all addons then reinstall (serial numbers will be needed). This article is on RW7 but should still be mostly right(addons folder default location moved). I run AppTrap a freeware app delete program that does a pretty good job of deleting all library files and relics when you delete an app. It runs in the background and pops up asking if you want to delete the supporting files(if you leave it running it asks you for app updates so say no and keep for normal updates). There are other apps that uninstall available as well. Once you delete RapidWeaver and addons reinstall RW and stacks re-enter serials and test.
  3. If still broken then you could try a macOS reinstall.. Time-consuming but non-destructive.
  4. And finally the dreaded macOS Mojave clean install. Requires everything to be manually reinstalled. Make sure you have all serial numbers for all your apps.

Since I’m going to be on Mojave for a while (not even looking at Catalina till next summer). I’d go through the steps. But if you’re going to upgrade to Catalina soon then you might just go that route. Although you might need a clean install of Catalina to fix the problem.

Anyway good luck.

1 Like

Thanks for the in depth help. To comment on some of the matters:

I uninstalled RW completely, including it’s little bits wherever they are, I’m well aware of Library’s and App Support etc… uninstalled all stacks etc., and went backwards to RW7 and older stacks etc., and it didn’t help. Same problem. Edit mode weirdness.

I have a Catalina virtual machine for testing my software and notarized installers because I’m a software provider, a developer… so I tried RW 8 in Catalina and lo and behold I got the normal edit mode. Things have borders. Yay.

So I have taken up working on RW in Catalina, leaving my Mojave problems unsolved but behind me. Fusion makes working with a virtual machine no problem at all, you can copy back and forth between the virtual and main system with ease, use FTP in whichever you can or want, time machine backs up the whole virtual machine every time because some part of it changed, changing the whole virtual hard drive, so it’s big but it’s covered.

It MAY be this odd thing, that I can’t get rid of…my Mojave user name is Das’s, yes it has an apostrophe in it, this has caused problems at other times, but rarely, I can’t change it because Apple’s notarization somehow remembers it, I tried changing it, and it wouldn’t notarize my app for me anymore, begging for Das’s to come back… so I’m stuck with it. I don’t mind.

Running two OS’s has it’s advantages in terms of you can do things differently in one as compared to the other. It’s not problem with fusion, it’s just a full screen app if you wish, or in a window if you wish. I do both. It’s fast enough.

So at least I’m able to Weave, in Catalina, which is just fine.

I too am going to keep Mojave for a good long while yet, as iWeb is in it on my Mac and won’t run on Catalina, and I need it for maintaining my big website that’s in it, as I gradual weave up the alternative new… the changeover will take time.

I think you’re right that the Mojave problems are my own to solve, because I think many are on it with no problem. Could be my home path name with the apostrophe. Who knows until you try tons of stuff that take time and effort.

How do you add Google fonts, or any fonts, to a RW project…? I dont see a Fonts menu in very many places, where I do see one it says like Font 1, Font 2, but I can’t assign them there. I know I saw on some video that you put them in somehow, can’t remember how they did it though.

Das goravani

Slightly off topic but if you have MAC OS in a VM on your iMAC do you need a second license for the OS?

No, Apple’s OS’s are free, and by the way, I recently got a call from Apple and they viewed into my computer, to gather log data on Catalina install delays, and they saw that I have a virtual machine, and said nothing… it’s totally not an issue, virtual away !

You’re using Foundry, correct? Look at the Typeface stack. You’ll add this to each page and set it to load the Google font and to assign it to one of Foundry’s default fonts.

If you haven’t yet read about Partials in Stacks, you’ll want to read up on them. They allow you to create a group of stacks that can be used on multiple pages which allows edits to affect multiple pages. The main Foundry stack, the Typeface stack, banners and footers are good candidates for inclusion in Partials.

See partials section here:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.