Contact Form help. Please!


(norman) #1

Hi guys!

I’m using the latest version of Rapidweaver 6 and I am having a terrible time trying to get the Contact Form to work.
I searched through all the forums and checked all my settings.

PHP is enabled on the server end, I think it has something to do with the way Rapidweaver is compiling the site.

Prior to this problem I was unable to get anything to show up on the web after exporting the site, I did a search and found this here:

Quit RapidWeaver 6 before opening the Terminal app. If RapidWeaver 6 is located at /Applications/RapidWeaver 6.app then copy-paste the following command in its entirety and hit the Return-key.

xattr -rd com.apple.quarantine /Applications/RapidWeaver\ 6.app/Contents/Frameworks/RMSnapKit.framework/Versions/A/Support/com.realmacsoftware.rmsnapkit.websnapper
We’ve filed a bug with Apple about this: it appears that, when RapidWeaver is decompressed the Gatekeeper system doesn’t correctly unblock all the components in RapidWeaver.

I did as it suggested and now I’m able to get almost everything going, except email.

Help!!!


(Mark Sealey) #2

Two little things jump out at me here, norman:

I was unable to get anything to show up on the web after exporting the site,

There is an additional step necessary - actually to Publish your project; could that have been the missing step?

Then, the xattr command which you entered at the command line (Terminal) probably has nothing to do with the functioning of RW; more with installation of the software.

Are you using the built-in Contact form?

Do you get any errors when publishing?


(norman) #3

Oops, yes sorry, I should have said that I am publishing the site.
I am using Cyberduck and directly placing the files on my server via FTP.
I tried using the publishing option in RW but it just hangs forever.

I get no errors after placing the site on the server other than the server error. It’s crazy, the contact form has worked perfectly up until now.

And yes, I am using the built-in contact form.

Thanks for your reply!


(norman) #4

Also, I just tried publishing again via RW Publish feature and it worked fine. Still, the contact page shows up but when I click on it I get a Server error.

Man, what a bummer, this used to be such an easy to use program… :[


(Jannis from inStacks Software) #5

Which server error do you get?


(norman) #6

Hello,

I got the following:

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@brianwrentattoo.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I even tried publishing a site that is currently running and has working email.

I don’t understand…


(Mark Sealey) #7

Successive versions of RW seem to be making the publishing experience increasingly reliable; IOW some users have had problems. Are you using 6.6.4?

I’d stick to RW’s built-in publish routine rather than ftp-ing to the server.

Have you tried adding a brand new Contact page with a different (and so ‘untainted’) name like secondcontact.php, making sure that it has the .php extension and republishing, having gone through all the settings one by one?


(norman) #8

No, I’m using 6.3.4. I did not know about 6.6.4, thanks!

I will try making a second contact page s you suggested, clever idea.

Thanks!


(Mark Sealey) #9

Typo, of course; Yes 6.3.4 is the latest. Sorry…

Let us know how your test duplicate goes.


(Jannis from inStacks Software) #10

For me, this does not sound like a RW problem. Check the PHP log -> hoster.