Cookieless domain with warehoused images in ProGallery 2 directory of images


(Lisa Sandler) #1

Can someone help me with this? How do I get a domain that sets cookies? I think I want cookies. I mean, yum, right? :slight_smile:

@willwood


(Doug Bennett) #2

Not sure what you’re asking? Your domain currently uses cookies (google analytics). Don’t know what the screen shot is from?


(Lisa Sandler) #3

Its Pingdom. I don’t know what it means, but it set my score back and I figure there is something different about these particular images.


(Doug Bennett) #4

Never have used them, they don’t seem to explain anywhere on the site what they mean.


(Lisa Sandler) #5

I will ask my SEO friend next time I talk to him, but I thought someone here might know. Ah well. What do you use to check your site for performance?


(Doug Bennett) #6

I use
http://www.webpagetest.org/

You can set server location, the connection like cable DSL or 3G and a lot more under advanced. The reports are clear and easy to follow.

Just ran your /portfolios/headshots/ page and it looks like those images need compression.

You can also use the network tab in Chrome/Chrome Canary.

Google own https://developers.google.com/speed/pagespeed/insights also can give you good data and if you click the link at the bottom you can down load optimized images:


(Lisa Sandler) #7

thanks, Doug.
I keep compressing and compressing and I feel like I’m going to start losing quality. I’ve got 2 sets for everything… a thumbnail size for mobile and a regular size for larger screens. If I don’t make my files at least 500pixels wide they don’t fit certain boxes. But that is another story. I reduced them in Photoshop and I also used Squash to further compress them.


(Doug Bennett) #8

You could run your page through Googles insight above and click download at the bottom. THe images are in a sub directory and take a look at the quality of the picturess it produces. I’ve never felt that Photoshop (at least the older versions) did a great job of compression for the Web.
Compression is subjective; I see a lot of folks over using it, getting tiny file sizes, but noticeable distortion in the images.


(Lisa Sandler) #9

thanks. This is a real source of frustration for me in my website speed so I’ve got to do something about it. My pages are 90% images.


(Doug Bennett) #10

The page I ran the test on is 94.6% images, 6.4 MB of images. Google thinks it could reduce by 2.5 MB. That would make your page load much faster. It also doesn’t look like you have CloudFlare turned on. That will help a bit as well.


(Lisa Sandler) #11

Right. I’m keeping CF off for now until I finish updating.


(Lisa Sandler) #12

Doug-
I cleared much more than 2.5mb on this page by running images through Squash again. https://www.lisasandlerphotography.com/portfolios/headshots/
Can you check it again and see if you find improvement? It’s my plan to run all pages on Google speed test myself, but curious to see if you see a big difference.
thanks, Lisa


(Doug Bennett) #13

Looks better, dropped quite a bit of load time. Still a heavy page, but with all those images it’s going to be. Compression is showing good. I ran the test with web page test, and the only flag was for CDN (CloudFlare).


(Lisa Sandler) #14

Thanks. I guess I’ll go back and compress more on other pages, hook up cloud flare again once I get all these changes done. Much appreciated.


(Lisa Sandler) #15

Doug-
I’ve done a lot of work on these pages. I turned Cloud Flare back on but does not seem to be showing… I get an X in “effective use of CDN”.
Also, a couple of pages that have multiple PRO GALLERY2 slide shows are giving me Fs in first byte grade.
Any ideas on how to get pages like these pages faster? https://www.lisasandlerphotography.com/portfolios/lifestyle/


thanks, Lisa


(Doug Bennett) #16

I just tested the page above and got the following:

You don’t appear to have CloudFlare turned on, at least not for a cache. If you select details:

2017-08-15_09-55-19

Then select one of your jpeg’s and get the response details, your site is coming up http1.1. CloudFlare uses http2.
You can also see that your missing cf-Cache-status:

A CloudFlare cached site:

2017-08-15_09-52-18


(Lisa Sandler) #17

Doug, as always, thank you for your information and help.

I’m in Chillidog, so CF is built into the CPanel. What am I missing? or is it in the domain area?

And glad you are getting all As. I can’t seem to get more than a D, usually an F in first byte.


(Doug Bennett) #18

I have never used the cPanel version. I’ve always used the sign-up free version. I have my Google Chrome (canary) set up to show the protocol for sites and this is what I see for yours:

2017-08-15_10-27-33

On a CloudFlare Cached site’s you should see h2 or http/2, indicating it is using http2"

2017-08-15_10-27-01

Might be a question for Greg at Chilidog.


(Lisa Sandler) #19

thanks Doug… I put a note into @barchard already. I know I had it set up before, but I must have turned something important off a few months ago when I was updating my website so often it was more harmful than helpful.


(Lisa Sandler) #20

Greg said cloud flare wouldn’t show up as CDN in my testing.