Couldn't sign in your FTP server (Again)

I run 3 web sites, all on the same server. Same company. One of them keeps telling me Couldn’t sign in your FTP server. Had this problem before, but went away with an upgrade. Problem is, It will publish, then at the end, I get the message, only way is to get out there is to Force Quit. Very annoying to have to do that overtime I publish… Any ideas??

What version of RW are you using? The 7.4 beta has some known issues with this.

I just checked, I have version 7.3.3 I hope problem gets solve soon… My other 2 web sites dont have the problem, I can publish, click dont back up, it freezes, I quit force, and start all over again…

I have the same problem with needing to force quit RW after ATTEMPTED publishing. I get the same message about not being able to connect with the ftp server. I have not changed any of my settings, and have verified them all, as well.

Might want to contact RealMac support since you are running a production version.

In this KB article it tells you how to get them some log info:

They have been on this for me since April 10. Hoping for and expecting great things soon!

I wish. I use three different servers. ALL three sites can no longer be uploaded. RW crashes regularly. I sometimes cannot save my work because RW freezes, requiring a force quit (I have waited up to 5 hours, hoping for the best…).

The bosses are unimpressed with my ability to publish and maintain a web page for online registration. I am expecting to lose one, if not two of my three sites, for future RW use. That leaves me with one, and it is a personal use site.

The sound of crickets is almost overwhelming.

@Waiopai, @keviebaby, if you guys are willing to forego direct publishing from RW, there is an easy and 100% reliable method of publishing. I keep repeating this almost every week and twice on other weeks, because there is so much complaining about RW-publishing (the worst feature of this app).

Export your site locally, then upload it manually to your server using any FTP client, like Transmit, Yummy or FileZilla… Works every time…

I own Transmit ftp and I have used it a lot when RapidWeaver had problems before. Nothing beats the convenience of the integrated publishing in RW. 3 websites, all on the Maui Net, sub domains of one main domain. 2 work fine, my main one doesn’t… I can publish and force quit every time… Annoying…

Emiliano Achaval
Waiopai Fishing Charters


I’ve tried to export and publish through Cyberduck… RW crashes EVERY time I try to export… Good call, though.

Are you using PlusKit in any of the pages?

1 Like

(oh, oh…) Yes. Yes, I am…

I’m not using PlusKit…

Emiliano Achaval
Waiopai Fishing Charters


There has been a long discussion. Please duplicate your project, delete the plus kit and try again!

Let’s not forget this is my thread asking for help… Lol

Emiliano Achaval
Waiopai Fishing Charters


Deleting the PlusKit page stopped RW from crashing when trying to upload, but did not fix the ftp problem. I will try to export the site so I can upload via CyberDuck (exporting ALSO caused RW to crash).

I suddenly had the same “Couldn’t sign in to your FTP server” problem in the middle of updating a Rapidweaver 8 site. It was after doing a number of “publishing” runs, then it wouldn’t do it anymore. No trouble uploading the files, using the same settings, with Yummy FTP Pro. Rapidweaver says thumbs up when you Test the setup. Now none of my web sites will upload. Using version 8.0.3. Weird. (also tried rebooting the iMac, changing the FTP server password, deleting the FTP settings and re-entering the info)

First off, I doubt the problem your having is the same as this post, it’s two years old and using different versions of RW. I bet Rob (@Rovertek) doesn’t remember this post either.
I would suggest you start by going through the KB article:

If that doesn’t resolve it, then open a new post with the steps you have gone through, It’s helpful if you include some screenshots of the publishing settings, hosting company, and the exact message or problem that occurs.

1 Like

This topic was automatically closed after 3 days. New replies are no longer allowed.