Dispatch Dropbox authentication process giving error


(Carolina Caetano) #1

I am not experienced at all with any of this, so forgive if I am just doing or asking something stupid.

My website has some pages in which students can upload homeworks. See here: http://www.carolinacaetano.net/teaching/eco231w/upload/page14/index.php. This uses Dispatch Dropbox by Joe Workman.

The problem is that I need to authenticate it, but when I click on the link it gives a bizarre error.
It used to work fine, but it started giving me problems a few years back. I tried many things to the point that I frankly lost track. The last thing I did was to delete the dispatch file inside my dropbox (in the hope that it would ask me to authenticate again and maybe finally work). I tried returning the file there, but nothing changes. I tried creating a new page, but nothing changes. Oh, I even bought dispatch dropbox again, in the hope that there was a new version or something.

At this point I would like to start again, but I cannot find any documentation on how to do this. I don’t know how to make dropbox forget I ever had dispatch working there so I can authenticate properly again. I am not experienced or good at any of this. All I wanted was to provide a way for my students to upload their homeworks which had some functions offered by dispatch (renaming files, sending an email, restricting the number and types of files). This worked well for some time and now all my system depends on this continuing to work, but I had no luck trying to fix it.

Please help!


(Doug Bennett) #2

I have never used that stack but here is a link to the documentation on it.


@zeebe Does support for Joe, me tagging him here should get him to help out.


(Carolina Caetano) #3

Thanks, I have read their documentation, watched all their videos and searched all of the answered questions they have abou it, without success. I have contacted their technical support and I am waiting to hear form them, but the situation now is rather urgent and I may not hear back on time. I arrived at this forum from a link on their website by the way.

Again, I should add that I am not a pro at any of this, so they may have written about this, but it went over my head.


(Doug Bennett) #4

looking at the error message that I get it appears that Joe may need to upgrade his stack to use Dropbox version 2. Version 1 was retired (by Dropbox) back in September.

Fatal error: Uncaught exception 'Dropbox\Exception\BadRequestException' with message 'v1_retired' in 

https://blogs.dropbox.com/developers/2017/09/api-v1-shutdown-details/


(Carolina Caetano) #5

Thanks again! So, if this is the problem then a lot of people should be having the same issue as me, right? I am using Dispatch 2.3.1, which I believe is the last version.


(Doug Bennett) #6

I would think anyone using that stack could be getting that error. I don’t own that stack so I can’t tell you what the current version is, but since you just repurchased it, you should have gotten the latest version.
Someone else on this forum might be able to check the version and see if they are having the same problem.
@joeworkman or @zeebe could tell you for sure.


(Mathew Mitchell) #7

First, I hope you get your problem solved soon.

But if worse comes to worse, there’s a very good alternative. It’s the Repository stack. I use it in all my courses now for students to upload/download work. More here:
https://instacks.com/repositorystack/

My guess is Joe or Rob will get you sorted out in no time. But if there’s some really weird thing going on that can’t be resolved then there is an alternative.


(Carolina Caetano) #8

Thanks to both of you. Doug, thanks for tagging Joe. Mathew, I will be checking the Repository stack.

By the way, I just thought of one thing: I am using Rapidweaver 5.3.2, and the latest version is 7.5. There could be a problem in the interaction of the current dispatch stack and the old Rapidweaver. I checked and I first bought dispatch in August 2012. Don’t know which version of dispatch was available back then, but maybe it played well with the version of Rapidweaver I own. Maybe I updated the stack and this is why it broke.

I don’t want to update Rapidweaver because I’m afraid other stuff in the website may break too.


(Robert Ziebol 🖖🏼) #9

Sorry, was on a ski trip today with my son. Unfortunately, the Dropbox group changed their API and some work still but others do not. We can get you the Dispatch Server stack for free if you like, but if it stops working, it probably will not work again.


(Carolina Caetano) #10

Thanks Robert. So, from what I can see this may be fundamentally unsolvable. I actually just purchased the bundle with Dispatch Dropbox, Server and Amazon. Unfortunately I just saw that they require Rapidweaver 6 and 7, and I have 5.6. Considering that I won’t be able to use them, I would love a refund.

One thing I could do is to download Rapidweaver 7, create a new page, and try to start again. In any case, I don’t have time to do this. Unfortunately I cannot follow Matthew’s great suggestion because this too would require me to upgrade my Rapidweaver. I’m too afraid of upgrading and breaking the rest of my page, it happened once. I will search for a remedial solution probably request files with Dropbox, which is a bad method but at least it works.

Thanks for all the help. I did submit a ticket to Joe Workman and if someone from there is willing to help me through this with a bit more hand holding I am willing to keep giving this a try. It was a great feature while it worked.


(Robert Ziebol 🖖🏼) #11

If you can, send in a support ticket (like to have a record on our end) with your email you used to purchase or your invoice number (preferred) and I will get that to you sometime tomorrow. Very tired and sore after a day of skiing…


(system) #12

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.