Having problems with Joe Workman's Dispatch stack


(Michael Martinez) #1

I recently tried to implement Joe Workman’s Dispatch Server stack on a site hosted at LittleOak with no success.

It appears that I can not get Dispatch Server SFTP, Local or Dispatch Dropbox to work at all.

Does anyone have any experience with the stack or with LittleOak that could point me in the right direction?


(Robert Ziebol 🖖🏼) #2

Do you know what version of PHP you have running on the server?


(Michael Martinez) #3

It is running PHP Version 5.6


(Robert Ziebol 🖖🏼) #4

OK, that is not the issue, do you have a test url we can look at


(Michael Martinez) #5

Phpinfo: here

Link to page <-- Local

I really want to use the SFTP version, but that is not working.


(Michael Martinez) #6

I can Email you an FTP login if you wish. Just let me know where to send it.


(Robert Ziebol 🖖🏼) #7

My first guess is you can not have two Dispatch stacks on the same page. Remove one.


(Michael Martinez) #8

I added that to show the two things that I tried…originally, I only had one.

What I really want to accomplish is getting the SFTP option working, because this is the best solution for us and the reason I was drawn to Dispatch in the first place.

I don’t mind that it is not working right now, as I get to understand how to troubleshoot these kind of issues better.

But I don’t seem to have access to any logs or anything that would shed some light on the problem. The SFTP server that I am connecting to is used by us all the time for SSH connections, so I now that the address, port and etc are correct. I just don’t understand how you accomplish the sftp connection and if the host could be doing something that might get in the way.

Thanks for your help!

Michael


(Harry Logtenberg) #9

Hi @Digitalmt,

For me both dispatch stacks (server and dropbox) work perfectly.
I use chillidog hosting.

Best regards,

Harry


(Doug Bennett) #10

You might contact little oak hosting support. There is away to enable logging would be in logs directory if enabled. They have excellent support by support ticket, live chat and phone.


(Nik Fletcher) #11

If you’re SSH-ing into the server usually, have you made sure that for the stack that the username is able to authenticate with just a password (just in case you’re authenticating with SSH keys in other SSH connections)?


(Michael Martinez) #12

I suspect that it is a problem with the host, but it would be nice to be able to see what connection strings are generated, so that I could try them out manually.