Does rapidweaver 7 support TLS1.2


(najeh davenport) #1

does rapidweaver 7 support TLS1.2 my hosting company has upgraded to a sftp or ftps. they said that rapidweaver would need to support TLS1.2


(Rob D) #2

TLS has to do with security certificates, not with software you use for web developing. Am I misunderstanding your inquiry?


(Ben Balser) #3

Since RW acts as an FTP client to upload your files, yes, it does need to be TLS1.2 compliant.


(Rob D) #4

I see your point. Since I never use RW for direct publishing, this fact has escaped me.


(Doug Bennett) #5

Being that TLS1.2 is a ten-year-old standard, it’s pretty safe to say that RW will support it. RW offers both SFTP and FTPS publishing methods. Setting either up can be a bit tricky, I find FTPS a little easier. Your hosting company should have info on settings needed for both.


(najeh davenport) #6

I wish it was that easy, but there repeated statement is “we have no expertise with that ftp client, but you may upload from FileZilla” I can connect to the server from FileZilla but not from RW


(Doug Bennett) #7

What hosting company?
What version of RW are you using?
Did your hosting company tell you to add a port?
Are you using SFTP or FTPS?
You can export your site to a local folder and use FileZilla to publish since FileZilla seems to work.
In RW7 you can use the publish to folder option, or in RW5 6 7 you can from the file menu select the export site.
Go to a new folder, so it is clean of anything else.
I have never used FileZilla, but most FTP clients have an easy way to select a folder on your Mac and a directory on your host.


(najeh davenport) #8

Aabaco hosting formerly yahoo
Rw7 latest update
No they didn’t give me a port but when I connect to FileZilla it gave my a port along with an ip addy.
I’ve tried both sftp and ftps with the same results
I ve tried export folder to ftp client but I’m have to grab a couple YouTube tutorials to work this out. My only problem is I’m. It sure how the uploading to ftp client works when it comes to the actual website. If you know of any guides please send them over


(Doug Bennett) #9

OK,
Took a look at a help page from them.

Here’s what I would try from within RW publishing settings:

  1. Set Publishing method to FTPS
  2. Set Sever to the FTP server name they gave you - add a colon and 21 :21
  3. Leave path blank for now
  4. set Mode to passive
  5. set Use SSL for to Nothing
  6. enter you Username and password
  7. hit the test button

See what that does. You can try changing Use SSL for, and Mode If you get an error.

Looks like they are recomending cyberduck for FTP:
https://cyberduck.io

Looks like they have a step by step guide:
https://help.smallbusiness.yahoo.net/s/article/ka21a0000009ZvEAAU/SLN29176


(najeh davenport) #10

I’m getting errors regardless of what I do, but thanks for your time.


(Doug Bennett) #11

Yeah, sometimes it can be tough to figure out the right combo.

You could go with the stand alone FTP client there’s a few of them, that’s what a lot of us use.

If you want to keep trying with RW
Here is a KB article from RW on publishing problems:
https://kb.realmacsoftware.com/article/1-how-to-fix-ftp-publishing-issues