RW7 cannot upload with TLS/SSl


(Ralf Schroeer) #1

My Hosting provider changed from FTP to TLS/SSl.
Now I cannot upload from RW 7 directly to my server. I can upload my files with Transmit using the new settings.
The screenshot shows the working settings with Transmit
I didn’t found a working setting in RW7 yet, nor did I find a setting that helped here in the forum. So I need your help with this.


#2

I am not sure you are on the correct port for secure FTP. It’s more likely to be port 22.


(Ralf Schroeer) #3

Port 21 works good in Transmit.
By the way I don’t know where to put the port-number in the RW-Settings. To tell the truth I don’t know anything what to do there.
Is it FTPS or SFTP?
Which mode passive or active or Extensed passive?
I tried nearly everything,…


#4

In my case I use Yummy for FTP uploads because I find it more reliable than RW. My sites are SSL and port 21 works for uploads but root access to a server generally requires port 22. You shouldn’t need that for normal site uploads.

You are right that there doesn’t seem to be an obvious way to change the port number in RW. I think what you need is the setting SFTP but you can try both. Extended Passive is generally the safest option for most server. Personally I would just stick with Transmit if you have that and it works. I agree it’s a pain though…


#5

What I now do is to the set up a local export setting so that pressing publish in Rapidweaver exports updated items to a local folder. I then use Yummy FTP to synchronise those changes to the server and it’s very reliable.


(Ralf Schroeer) #6

Thanks for this. I’ll give it a try, although I’d prefer a method to direct download from RW as it worked for me since RW3.


#7

I didn’t want to use Yummy instead of Rapidweaver for FTP uploads because this involves an extra step but I am finding this much more reliable and there is the added advantage that it keeps the server better organised by deleting unwanted content, which Rapidweaver does not do. There is a Yummy app called FTP Watcher that can automate the entire process and I may get that when they next have a sale. http://www.yummysoftware.com/Product-Information-Watcher/