Drag and drop images won't work in 8.7

Just after upgrading to 8.7 from 8.6.2 now when I drag and drop an image file to a page (styled text page type), it shows up in the edit mode but is missing in view mode or when I publish it. Please help. For YEARS I’ve been dragging and dropping image files to styled text pages and they show up just fine… not so now that I’ve upgraded to 8.7.

Jeff

1 Like

Sorry you are having this problem. I have no idea why this is happening to you. I just want to bump this thread. Also someone like @Aaron from RealMac might be able to help you.

What system are you on macOS 11, or earlier?
Does it do it on all images? or just this one?

The reason I ask is because it can sometimes happen if RapidWeaver doesn’t know the image type, or it’s named incorrectly. Perhaps it’s a png when it’s really a jpg. Just a thought.

If you’re really stuck, you can download previous version of RapidWeaver here:

Let us know more details and we’ll hopefully be able to get you back up and weaving.

Thanks
Dan

Yes! Open my site after updating to 8.7 and banner images and other are just gone in Cates Writer theme and “Venture” theme - unlinked all over the site - yet Resources images still there( I can see them), code correct to see images and nothing, just “?” I’ve relinked, etc. Nothing working - WTH? This is not the first time I’ve updated RW and things got whacked. Frustrating.
Big Sur 11.1. Things may have gotten wonky after update to Big Sure and switching hard drives etc.? Fine, but I’ve relinked, readied some image sas a test and it’s like a steel wall - will not show in preview as the OP is taking about - help!

I tried installing previous version - no go…

BUMP.
Can not drag an image into RW. Trying w/ Foundation. Drag and drop jpg into image stack and NOTHING. WTH?
RW 8.7 MacOS 11.1

If you’re having issues dropping images into Stacks, I’d check that you have the latest version…

Can you drop images into a new project? A short screen recording would be useful to see what’s going on.

Cheers
Dan

1 Like

@Tim3308 - As Dan says, updating to the latest version is a good first step. Outside of that, I think a bit more info about the specifics might help us diagnose the issue.

  • What images have you tried?
  • Are there any error messages when this happens?
  • Do the images seem to drop, but appear with a “?” question mark icon? Or seem to drop, but nothing appears? Or fail to drop and zoom back to their starting point?
  • What version of Stacks do you have installed?
  • What other addons do you have installed?

Isaiah

1 Like

Hi Dan & Isaiah,

No error messages. Just won’t “take it”. This: “fail to drop and zoom back to their starting point”
I keep stacks up to date.
I kept the latest update to RW, scrapped the whole damn thing and immersed my self in Foundations6 stack and rebuilt the last several days. Gave me a dead end excuse to remodel, so to speak.
I could not use a single jpg image that was linked to any of my previous RW builds to even the new Foundations6 build. Not even copied over to a new folder. No go, would not accept as you try to drag and drop. It’s like RW update put a stink eye on all jpegs that were associated w/ anything of previous use in RW before update. Completely stymied in this regard. As an illustrator this meant that a ton of saved images were essentially useless.
I will also never make the mistake again of having linked files (An update in the past had done this to me once before). I will make sure RW is pref’d to include images in RW files, not linked, as is the case w/ much of Foundation (drag to side bar window and not a stack in main window).

Thanks!