RW8 new resources images not working

Just tried the new resource manager with an image. Dragged into resources fine, dragged from resources to a stacks page (standard image stack), looks fine in edit mode. In preview mode, Simulator and when publsihed I don’t get the image. but get the alt text:

1 Like

I can replicate this. Just pinging @isaiah


Yes, indeed is a bug. Seems like it’s treating resources as Unsplash images and using a full path – which isn’t allowed for local files.

I’ve marked the problem, it doesn’t look too difficult, I’ll see if I can tackle it in the next 24 hours.


Don’t think this is a Stacks only problem. Tested with a Markdown page per @ben’s New video and drag and drop from the new resource manager doesn’t work for local resources on the markdown page. It does work on a styled text page.
tag @dan

Also Problem with image stacks that use Warehoused images that link to local resources from within the link setting. Works fine if you use an Unsplash image.

These may be different problems after all

update on the Markdown page with the drag and drop with local resources.
If you drag onto a markdown page from a local resource you get this markdown code:


The first part within the square brackets [ ] is the alt-description. The file name contains a ~ that gets put into the alt description as well as the file name. If I remove that ~ character from the alt-description it works.

@teefers: thanks for the bug reports. I can’t comment on the Markdown issue – that’s RW specific and I’ll leave it to @dan and @simon to work on it.

But I’ve fixed the Stacks issue. I haven’t pushed it out to all users yet because there were a couple other bugs I was tracking this morning to see if I needed to include in the release (they’ve since evaporated or been found to be non-stacks things, so we’ll probably go to full release tomorrow or Monday).

If you want to see it now you can hop onto the stacks Slack channel and grab it, test it, etc.

The Stacks Slack is open to all and is where I do all the beta testing:

Lastly, here’s a link to the public bug tracker for the issue. If you want to add any details, re-open the bug, or verify the fix, here’s the place:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.