Dreaded "operation was aborted by application callback"

Greetings all,

The following describes my situation tonight using Rapidweaver 8 Version 8.0.3 (20142); I am unable to publish files to an existing site (jitkavesela.com):


To find a solution, I first confirmed that my login credentials were correct. Indeed, they were:


So far, so good. I tried republishing, and, seeing the below message, thought the problem was solved, until…


…this popped up:


So I spent 30+ minutes working with my host provider’s Tech Support, who checked everything on their end, but came up with no solution. The problem, they said, is on my end.

I rechecked the credentials, and discovered that I could not see (or connect to) the website’s subdirectory when using the Browse button, even with the correct path set in the “Path” window. But when I removed the path, setting the path to the root (as shown below), all paths to my other sites on my host’s server became visible. I then clicked on the problem website’s folder, which then populated the Path window, at which point the Browse button functioned properly.

I thought that fixed the problem, so I saved my Rapidweaver project, quit and restarted it, then published it again.

This time I made it to 79 files uploaded…


…until I got hit again with this bit of joy:


I’ve tried exporting a test RW project and loading it by FTP to a test site, but the webpage failed to load. I do not want to bring my main site down with an experimental process (export-FTP upload) that has proven to me not to work. The solution must be found using RW’s publish feature.

If anyone has a solution to this problem, please so advise! Santa would be most impressed with your contribution.

Thanks very much for your help


1 Like

Try reducing the connections.
You currently have 6. Drop it down to 2.

And try the other settings beside “Extended Passive”

Hello Ric,

I unsuccessfully tried it at 3 earlier this evening. I just tried it at 1 connection; same result.



I also tried it in Passive and in Active modes; same result.



Thanks for your thoughts.


  1. What FTP client did you use?
  2. What was the results of the FTP process?
  3. If the FTP client produced no errors and “the webpage failed to load”, what did you mean failed (404)?
  4. What hosting company?
  5. Does the host company support SFTP?

If you can’t get an FTP client to upload using the same credentials, then that’s more than likely the issue. If you’re able to upload with an FTP client, but “can’t get to the website” than more than likely it’s the path you’ve uploaded to.

Use SFTP! It’s more secure and more reliable

If your hosting company doesn’t support SFTP, I would change to one that does. FTP does a lot more of “handshaking” and sends credentials in the clear.

As for publishing within RapidWeaver I would suggest you go through each step outlined in this knowledge base post:


If you go through all the steps, and still can’t publish. Follow the section

Still having issues? Let us help.

Including getting the log files.



For reasons I do not understand, I discovered that the problem had somehow resolved itself overnight after putting my computer to sleep last night.

This morning, having made no changes to anything on my iMac but to simply to awaken it and attempt to publish the problem RW project again, the process ran normally to completion:




This may point to a problem on my computer or my IP provider, but with Publish now functioning normally I have nothing to troubleshoot.

I love it when problems resolve themselves.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.