Easy CMS text styling


(leigh) #1

first admin / cms worked perfectly and no issues with text styling
second admin page the text styling isn’t working in this case BOLD ** **
see attached.
any suggestions pls ?
everything is up to date and works on one page but the other.
I duplicated the first page and added a new admin ( after removing the first one ) changed the text edit blocks but it still didn’t add styling.



(scott williams) #2

I’ve noticed sometimes that markdown seems to get confused. Try putting 2 spaces at the end of the first line


(leigh) #3

no that one didn’t work on this - i tried all combinations of two spaces too.
I cut and pasted the first page bold header and tried that but that didn’t show as bold either
removed the first text edit box and replaced with a new one but didn’t work.


(Mathew Mitchell) #4

There’s no confusion going on here. Markdown always needs two spaces after the last letter to signify end of line. This is very useful. A line break will do something very similar. So why both? For example consider a poem: it’s very useful to have a clean way to break up the various typically short lines of a poem. Line breaks typically signal a new paragraph: a paragraphs tend to have a bigger vertical spacing than 2 lines. (This all depends on the theme’s CSS.)

Also the behavior that @swilliam is noticing is also predictable Markdown behavior. The problem in this case is the use of the dash “-” as that’s telling Markdown you want to begin a list. Keep in mind Markdown isn’t “smart” and it goes by the cues you give it. So how to fix this? There are a few different ways, but one approach would be:

**first offer** - **buy soon**

Notice how I left the dash on its own and wrapped the other phrases in Markdown bold.


(leigh) #5

Hi thank u for your reply.
In Easy CMS you simply highlight the text required and click the bold button.
Im not sure why it worked on the first page and not the second.
Ive pasted in clean text ( formating removed ) but that hasn’t helped.
But thats probably as useful kicking a car tyre when it won’t start. !


(scott williams) #6

Thanks @Mathew, I’m not sure if it’s a cms thing or what but I sometimes have problems, especially if I try to go back and edit something after it was already saved once. Sometimes it can be fixed by adding a line feed and then removing it sometimes not. I haven’t noticed the - . I’m not a mark down pro but sometimes it seems unpredictable. I usually get what I want eventually and sometimes it looks exactly like it did in the first attempt.


(Mathew Mitchell) #7

Unfortunately I’m not using Easy CMS currently so I can’t speak to have it behaves. I know how Markdown “should” behave, but it’s always possible Easy CMS uses Markdown in a slightly non-standard way in some circumstances. Hopefully @zeebe or @joeworkman can speak to this directly.


(leigh) #8

apparently its the old www. verses the no www. issue but i dont know how to fix that.


(Joe Workman) #9

For some reason when you start the document with Bold or Italic markdown, it does not render. All you need to do is put in a return at the beginning and you will be golden. Sorry for the confusion.


(leigh) #11

I am now officially sorted out and Easy CMS is working fully and correctly. Try its good.
301 redirects in place - if any one wants a step by step copy of that process - in beginners terms let me know.
Thank you Team Joe for your patience with a member of the numpty brigrade.