Titles in blog post in brand new project align wrong?


(Uli Kusterer) #1

Hi,

trying out RapidWeaver for the first time (deciding whether to buy it). I used to do all my HTML by hand, but a recent mishap took my sites with it, so I decided it would be nice if I could just click together my new site. So I took two of my old articles and pasted them into RapidWeaver and they look bad.

If you look at the page RapidWeaver generated:
https://orangejuiceliberationfront.com/files/26d2138be04f3ca31f008931e089a568-1.html
you’ll notice that the first headline, “the past”, correctly has a gap between it and the preceding image. Subsequent headlines (even though they’re all styled as “Heading 2” are bunched up against the bottom of the previous paragraph.

Apart from a few changed colors and image files I dropped into RapidWeaver’s UI, this is the default theme I get when I create a new project. Surely that isn’t intended to look this bad?

Is there a trick to applying styles to text? I tried leaving empty lines, but it doesn’t help.

Do I have to edit the CSS to fix this (I thought RapidWeaver would let me get away from that)?

Thanks for any help,
– Uli


(scott williams) #2

First question would be, did you clear all of the text formatting when you pasted your text, then re-apply it? On my phone right now so I can’t look at the actual code.


(Uli Kusterer) #3

Yes, it happens even if I create a new blog post and type in six lines of text and just set the style of the odd-numbered ones to Heading 2.


(scott williams) #4

Are you hitting return before and after each heading?


(Uli Kusterer) #5

Yeah, that’s what I meant by “tried leaving new lines”. Try it yourself:

foobar
baz

frobnitz
boff

Think of this
hey this is amazing

Then triple-click or double-click and choose “Heading 2” for each odd line (for foobar, frobnitz, think of this) and you should see the headlines being too close. You even get this effect for the first line if you make the even instead of the odd lines headings.

Also, double-spacing the entire text is completely ignored for the purproses of leaving space between the heading and previous text.

At this point I’d say the default theme just has no top margin set for headings in its CSS.


(scott williams) #6

Sure sounds like the theme. Just targe h2 in the css for that page and add a top margin or padding, assuming there is no setting for it in the theme ui.


(system) #7

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.