Editor password to create blog post

How can I find where my password is on my RW website I can open on y computer as usual. To create a blog post I always had an automatic password one I typed in the word editor on my chrome search and that is not working, I never wrote it down, how can I find out how to recover my editor connection to create a blog

If you’re talking about the publishing settings password, they are stored in Mac’s keychain.

I have searched the keychain and I guess I cannot understand it. I do not see any passwords there. I have an apple macbook pro and very savy with it but never have lost anything before.

I’m not at a Mac right now so this is from memory.

The Keychain Access app, should show a listing of entries. You need to select the entry you want and then there’s an option to show the password. It will then promote you for either the iCloud password or an admin password.

I searched for recovery of passwords on chrome and there is no recovery.
RapidWeaver must have a system because the creation of my site created a password link to paste on chrome. Why is it so difficult to get something restored that was originally created on the new website? I do not understand the lack of support and help from the RapidWeaver team. Thank you for help and I need real help with this.
What would I do when I am creating a new website to get the link to type into chrome to access the editor. I cannot create a blog on the website as you know. I create it elsewhere and it saves to the RW site?
Do I have to move my website onto another platform like Word Press or squarespace to get support on a simple question. Is that what you do to struggling small businesses of a teacher and healer and educator who spends her life helping people.
I have to move from RapidWeaver to get help? and be able to blog again. This is insane.

This is simply not true. Nothing is stored in my key chain. I have opened everything. There is nothing there. I have followed all instructions.
How did the password link ever get formed in the first place when the website was created> I was just given it and I typed it in and it worked and google saved it. It is gone forever from google.
Are you telling me the only way I can ever blog again is to move from RW to Squarespace or Word Press.
it seems none of you even listen to my real question. I am very disappointed. A 78nyear old woman learning tech to be able to support my students cannot get help from any of you. Thanks for trying. Farida

@puretruth I honestly have no idea what you are writing about. “To create a blog post I always had an automatic password …”. Where were you creating to post? RW or on your browser? If on your browser how did you do it? (i.e. what tools did you use to create the post).

Put differently where is the prompting for a password happening?

By the way you show little patience … AND you didn’t take care to write down and store the relevant password. Your tone is not going to encourage folks to help you. But we will help as best we can if you can provide more specific details. Currently I have no idea what’s happening where.


It looks as though you are using Foundry and that the blog was created using Alloy. Does that ring any bells?

I’ve never used Alloy but perhaps @Elixir can chime in and advise whether it uses a password and where that password might be stored?


@puretruth: you write:

… do you understand that none of us work for RW. We are simply users of the software trying to help you as best we can. It’s not our job. We don’t get paid. It’s a friendly community.

… and your real question, unfortunately, is not clear at all. It may be clear in your mind but it’s not helping us to understand the real situation.

1 Like

If it is Alloy (not at computer right now to check) then you set up the password using the Setup Password settings in the stack.

Alloy has several tutorial videos on its site. You’ll want to watch the two Editor tutorials here for password features, but should watch the Getting Started video too: https://alloy.elixirgraphics.com/tutorials/

The documentation for Alloy can be found here: https://alloy.elixirgraphics.com/documentation/

As I have never used a keychain and have checked every entry this is not the path.
Rapidweaver created the password link of editor to post onto chrome search and so the answer must be in RW
I have never used key chain and do not have a key chain password so this is not the answer.
Thank you for trying. Thank you for offering. Farida

My RW website does not allow blog posting on the website on my computer. It provided a link I was given when the website was created that I typed into the browser Chrome and from then on it was saved for years. Chrome lost my browser links passwords and bookmarks so I am trying to figure it out.
All I can think now is I have to move from Rapidweaver as there seems no answer. I will have to move my site to Word Press because no one can give me the answer. Very strange. Appreciate your suggestion. Thank you for trying. Farida

Ahh yes I am in Foundry and using Alloy. Wish I had thought to say that before. Somehow somewhere a link was created when making the website that I put in the browser Chrome and it saved it, now it is lost, I am lost. Thanks for the progress. Very grateful. Will try Elixir.

Apologies. Someone just helped. In Foundry using Alloy the editor for the blog posts is a link that was generated to type into Chrome Browser which was then saved, only Chrome lost it. How to recover this link to enable the editor function to work off the website as it is meant to on Alloy. I hope this helps. Thank you for responding. Farida

Yes using Alloy. Will follow. It has always worked so well and enjoy creating posts. I lost 200 bookmarks, all my passwords off google and even google analytics so I am recovering a lot. Never add duckduckgo to Chrome. My fault for trusting a tech person before checking it out. It wipes out all your history so that is how you get security, no records, but ruins functioning of my school and all of my world connections with my lifework. Thank you for the links. Will follow through tomorrow. Much appreciated that finally someone is helping and I know now it must be confusing as there are so many RW options. Saying Foundry and Alloy opened up understanding. RW is potentially complex. I use it simply and the website is a mess. I think I must move to Word Press and get real help as struggling endlessly with RW is a waste of my professional time when I could be helping real people. Another huge project to shift but with Word Press I understand it better and can get real tech help. I had one some years ago. I liked the idea of designing and changing things but it is time to leave RW behind. Farida

Not sure what you mean… within 2 hours of your original post several people helped you and gave you a solution to your problem.


And that has absolutely nothing to do with RapidWeaver.

I’m sure you lost more than your password to Alloy.

The lesson you should have learned is to not use Chrome to keep the only references and passwords that are important to you.

Things like password management built in to any browser is for convenience only.


@puretruth Okay I will just assume you are overly stressed and not thinking as calmly as you usually do. There is a saying about not throwing out the baby with the bathwater: it seems that’s what you are opting to do. If you really lost all your passwords then you have much bigger issues to deal with!

Now that we know this is an Alloy produced blog there might be two relatively simple solutions:

  1. In your Alloy settings you created a hashtagged password. If there is a way to de-hashtag the password then you have a very simple solution. I don’t know if this is possible, but @Elixir will know.
  2. Create a new password (that becomes hashtagged in Alloy) to overwrite your old one. I’m guessing this is possible also but I don’t know what caveats may be involved. Again, @Elixir would know about this.

There may be other solutions that I’m not thinking of. It’s late for @Elixir so you may not hear back from him until tomorrow.


I just changed both my user name and password in Alloy for an existing site. That worked fine. As all you need to do is re-do the initial password and user name setting in the Alloy editor stack. The tutorials show this in detail. All the best!


Yes but the answer is watching two full videos, however I will do that and am grateful. What is easy for you as a tech person is very hard for me to do. I have struggled so much with RW in creating even two columns, one with a round photo and it takes about 50 tries to format the words properly in the right column on the top of my home page. No one’s fault. It is a fantastic system for tech people who have time for that. I do not even have the language to understand how to phrase a question. Only because I could. not devote the time to learning this platform fully. I cannot get the help of another program. Apologies that my lifework is so full time with people needing help and the reality that I have to transform an entire school of 43 years into virtual to continue doing so as there are no classes, retreats and immersions. I am finding my through, lost my position on google because I could not master RW but no worries there either as somehow people found me because of my reputation. I thank you sincerely and am not putting down your wonderful creation. I just need real website help adn real tech help with a website that is somewhere where help can reach it. Thank you once again. I hope I can understand the videos. From my world and state of being, tech people talk too fast, my 13# computer can’t show the samples big enough and the mouse moves too quickly. I will try. The key to health, consciousness and grounded intelligence is the ability to slow down and feel. I will do my best. Blessings and appreciation to you, Farida