Cannot publish without Keychain Access?


(Jeffrey Shaw) #1

We are transferring to a new web host so I have duplicated the project file and entered the new ftp publishing settings. But Keychain Access will not save the password - the dialog box that appears with the KeyChain Access options ‘Always Allow, Deny, Allow’, will not accept either Always Allow or Allow (it just stays there) and will only accept Deny. This means I cannot publish at all, because there is no way in RW, it seems to me, that I can just enter the password and go. I have posted separately to the Apple Discussion forum to find out what is up with Keychain Access. My old file, by the way, with the outgoing web host, still functions correctly.


#2

Same thing happened to me when I opened a Rapidweaver Project that was last worked on in January.
In the Bookmarks Window I noticed that the save FTP was missing the password info and when reentering it would not save and the Keychain request would hang.
I located the Rapidweaver folder used since Version 6.
(Library/Containers/com.realmacsoftware.rapidweaver6/Data/Library/Application Support/Rapidweaver Support) and found a solo Bookmarks.db file. Deleted it and restarted Rapidweaver. Reentered the missing info and this time it worked. The most recent projects I have worked on had all the correct FTP info and no Keychain request.
Not sure it that was the correct thing to do but saved the day.
Hope that helps.


(Jeffrey Shaw) #3

Thanks for the tip. Unfortunately it didn’t work!


(Jeffrey Shaw) #4

What do you know? It’s back. Maybe that bookmarks.db thing did work after all. At first I had exactly the same thing with the hanging Keychain Access dialog box - but then I (accidentally!) clicked the Publish button and - saints preserve us, it worked. Very happy!


#5

I did seem odd but I’m glad it worked for you.


(Jeffrey Shaw) #6

It was a false dawn after all. I have been able to publish occasionally, but for the most part that Keychain Access dialog box appears and will not either ALLOW or ALWAYS ALLOW and thereby prevents me publishing.


#7

The original Rapidweaver file dated 2-15-15 still has that issue when I hit Publish. Other files from around that date work fine.
After saving a fresh file with todays date works fine.
I did notice with the original file that when you hit Deny a couple of times the Rapidweaver publishing window opens and the Password is missing.
I wonder if it’s a corrupted Rapidweaver file? The theme I’m using is Henks HV Note if that helps.


(Jeffrey Shaw) #8

I’m hoping I have solved it. In Keychain Access I double clicked on the publishing login (chronologically top of the list of passwords), then Access Control > Allow all applications to access this item. I tried before simply adding RW to the list of permitted apps, but it didn’t ‘take’ - this time it did. So far it is working!