Error "Exception while exporting site" - Please help!


(Chris Mitchell) #1

Hi, I’ve seen this listed before but the latest time was almost a year ago and I need help.

I’m getting the “Exception while exporting site” error and it’s looking for a banner image. This only happens if I create a NEW stacks page and add it to the project. It doesn’t happen if I edit an existing page in my project.

The error says that I have “specified a banner but not provided one”. By default, my Master Style was set to an older one and I always changed the page theme manually (per page). It seems that it’s looking for something that isn’t there in the old file. For the record, there is no banner selected in RapidWeaver’s settings (I’ve checked my defaults).

Any help on fixing this would be MUCH appreciated.

I’m using RapidWeaver 7.5.5, and Mac OS X High Sierra.

Here’s the error:

-Chris


(Chris Mitchell) #2

Update: I spoke to Nick Cates (because he’s a genius) and he told me I should re-build the site. I did, but still got the same error message. It wasn’t one of his themes, he was just helping me out because he’s a swell guy. Just for the record, Nick is still a genius. Thanks Nick! @nickcates YOU ROCK!

I was able to fix it by simply dragging and dropping a banner image into the banner image box. Took me long enough to figure this out. It seems like this is an issue with either RapidWeaver and my Theme not communicating properly. I am using the Elixir Graphics Abstract theme @Elixir

Since the Abstract theme already has banner image capability, I’m not sure why I had to drag one that’s not being used into the banner box… oh well…


(Adam Shiver) #3

Hey there @ChrisMitchell! Just saw your post and your email! Hmmm… sounds strange for sure, and not something I ran into when creating the latest update for the theme. Let’s see if we can’t suss out the problem. Would it be possible for you to send me a ZIP file via email, maybe using Dropbox or the like, that contains your project file? If so, send that over, along with a helpful pointer directing me to the page you’ve added that has the problem. Be glad to see if I can’t sort it out.


(Chris Mitchell) #4

Adam,

I was able to solve the issue by simply dragging a jpg in the Banner Image box. Even though I was already using one in Abstract, for some reason it fixed the issue. Evidently, Rapidweaver was demanding that I was asking for something that wasn’t there.

-Chris


(Adam Shiver) #5

Go ahead and send it over anyway, I’d like to take a look and see if I can’t fix that for you so that is not necessary. :slight_smile:


(Chris Mitchell) #6

Adam, you ROCK! I’ll send over the original (before I added the background image). Just so everyone knows… @Elixir is an AMAZING RAPIDWEAVER DEVELOPER!! Great customer service!!

-Chris


(Adam Shiver) #7

Sounds good to me. I’m off to bed no – think Liz and I have caught a cold, either that or our allergies cranked up to 200% – but I will take a look at it in the morning and see what I can see.


(Chris Mitchell) #8

I feel ya. I’ve been sneezing like crazy for the past 20 minutes. :slight_smile:


(Chris Mitchell) #9

Adam,

I was able to install FlatButton 2 tonight. For some reason, RapidWeaver wasn’t set to open my stacks during install. That’s why it wasn’t installing. I did just recently update to High Sierra. I guess it could’ve changed some of my prefs somehow.

I’ve got it all fixed now (it is working well on the site).

Thanks again!!

-Chris


(Isaiah Carew) #10

Just out of curiosity, what application was set to open .stack files previously?

Also… make sure to click that “Change All…” Button down below there --otherwise you’ll have to do the same again the next time you need to install a stack.

Isaiah


(Adam Shiver) #11

Glad to hear you got it sorted out!


(Chris Mitchell) #12

Isaiah,

It was trying to install with StackInstaller 2.0.

-Chris


(Chris Mitchell) #13

I did click the “change all” after I figured out what was going on.


(Isaiah Carew) #14

Chris,

StackInstaller hasn’t been needed since RapidWeaver 5 – so probably good to remove that from your system at this point.

Isaiah


(Adam Shiver) #15

@ChrisMitchell I was able to recreate the bug with a brand-new project file here just now when trying to publish. I’m not seeing anything with the theme itself that would cause this problem, so I’ve messaged Dan and crew at Realmac to see if they have any insight.


(Chris Mitchell) #16

Yeah. I don’t know why it’s even still around. All of the other stacks and themes I’ve installed have been good to go. I wonder if the update to High Sierra Saturday had anything to do with it. I’ll remove it now.

Thanks!

-Chris


(Olaf Brandmeyer) #17

Just to let you know – same here with many of the new version 1.5. of my themes (i.e. Ruby, Geometric, Navigator, etc.) … I also fixed it with providing a banner Image in the general settings. strange …


(Chris Mitchell) #18

Good deal! I was pulling my hair out trying to solve this yesterday. Glad to know that you saw it on your end as well. Surely I can’t be the first person to experience this with RW. I didn’t feel like it was theme specific, either. It seemed like RW was essentially telling me I couldn’t do something that I wasn’t doing anyway. Like the old guy yelling from his porch “Stay off my lawn” when I was on the sidewalk. :slight_smile:

I hope they get it sorted out.

-Chris


(Chris Mitchell) #19

Thanks for letting me know.

-Chris


(Adam Shiver) #20

Yes, it looks like it is a bug with the way the RW banner feature reads and deals one of the settings in the theme’s PLIST file. I’m currently going through and making changes to them all again. Once they’re updated I will post here on the forum and to the blog and twitter letting everyone know how to download their themes and update.