Error Message RW7


(cyclingone) #1

Hi all

Okay…here we go

Just updated Joe Workman’s Foundation theme to 1.7.2.

Now, for some reason, I’m getting an “exception while exporting site must provide a launch path” error message when I try to preview changes to website. This is happening after updating the Foundation theme. I tried closing RW7 and opening it, but then I get the "your Foundation theme is out of date. Please update to version 1.7.2. AGAIN.

Also MagicGellan2 menu bar has not been working properly since upgrading to RW7 a week ago. Menu bar doesn’t scroll with foundation page, even though it’s set for fixed top. And Workman’s elevator stack not working properly either.

Sooooo…here we go again Have never seen an RW update that didn’t have me pulling my hair out…

Barry
SilkyWebDesign.Com


(Graham Jackson) #2

May not be an identical issue Barry, but I had a similar issue with the update nag about Foundation from RW7. I discovered that when I checked, somehow I had three versions of the Foundation theme in my RW folder. I deleted them all and re-downloaded the theme from Joe’s website and the problem sorted itself out.

Graham


(ben) #3

Hi Barry.

Really sorry to hear you’re having issues with 7 :frowning:

If you email support@realmacsoftware.com with the details of your setup (OS version, Addons installed) then one of our developers can take a look at it for you.

Side note: have you tried a restart? Stupid question, but I think it could fix this issue you’re seeing.

Sorry again, but drop us that email and we’ll help you get up and running ASAP :slightly_smiling_face:


(cyclingone) #4

Grajay:

Went into the finder to get rid of any other foundation updates. Still a problem. No problem with RW6 just seems to be with RW7, as far as asking me over and over to update Foundation theme to 1.7.2.

Thanks for trying…

Barry


(Robert Ziebol 🖖🏼) #5

Try this:

  1. Open RapidWeaver 7
  2. Hold down Command-Option and push 7, this opens the addons folder.
  3. Find the Themes folder and open it.
  4. Find the two Foundation themes, you should have a Foundation.rwtheme and a FoundationRTL.rwtheme. Click on each one and get info on it.

They should have a version number of 1.7.2. If it does not get them here:
Foundation 1.7.2 - http://foundation.joeworkman.net/theme/download
Foundation RTL 1.7.2 - http://foundation.joeworkman.net/theme/download/rtl

Now, do you need the RTL theme, no, not unless you make a site that goes Right To Left. So if you do not want that one, you can delete it. Also, if you find MORE than 1 Foundation theme, like Foundation-1.rwtheme or something like that, delete ALL of the themes and reinstall via the download links above.

Installing the theme by clicking or dragging and dropping is a known issue that Joe has contacted Realmac about, so hopefully in 7.0.1 or whatever the next release is, it will be fixed. You could just make a shortcut to the addons folder and install stacks and themes that way, that is what I do.

Hopefully this will help


(Jochen Abitz) #6

Sometimes the theme is not installed in the right folder if you double click the foundation theme file. Press CMD+ALT+7 in RW and a finder window should open. Copy the theme file in the folder “Theme” of this window (overwrite an old file if it exists) and try again to preview. Should work now.


(Graham Jackson) #7

I think the latest update toi RW7 will fix your problem Barry.

Graham