Something broke my site


(Mike) #1

RW Version 6.3.8 (15165)
Foundation 1.4.4
Top Bar 1.6.5

As an infrequent RW User, I am getting increasingly frustrated that every time I update my site, something breaks. It took me a good 6 hours a couple of weeks ago to install the latest set of Foundation updates and a great deal of angst.

I have tried this morning to make a few minor changes to my site - adding a new Newsletter page to the site, but now find that the Top Bar Menu doesn’t show it’s drop down menus on any page.

The code I have added (which previously worked OK on my published site) for the menus is:

and

for the two drop down menus.

This no longer works.

I have changed no settings / parameters - all is as it was prior to the updates.

I am also for some reason unable to upload my site either, so cannot show a working example.

My previous project backup created on 22-09-15 also has the same symptoms.
A backup export folder created on 02-09-15 works.

Any ideas?

Thanks in anticipation.


(Robert Ziebol 🖖🏼) #2

It seems like you need to update your Foundation theme, you have 1.4.4 and the one that will work with Top Bar 1.6.5 is Foundation 1.6.2. RapidWeaver does not does this automatically, so you will have to go here to get the theme:
http://foundation.joeworkman.net/theme

If you want automatic updates for themes, we suggest you get the Waterfall plugin by Nimblehost - http://nimblehost.com/store/waterfall/
Foundation works great with this and if you add the Waterfall plugin to your project file, it will check for updates for you.


(Mike) #3

Hi zeebe,

Thanks for the info. It worked.
How come updating RW / Foundation is such a hit and miss affair? Every time there is an update, something goes wrong along the way.

I have had no “error” messages saying to the effect “Foundation needs updating” recently. Why can’t all the updates be downloaded automatically, or at least a link that works, which takes you to the appropriate download page?

Cheers,

Mike


(Robert Ziebol 🖖🏼) #4

We are working to make this better, but as I stated, as of right now, RapidWeaver does not allow for updates of themes. Will this come? Unknown, but it is not something we can fix. As far as the error message, we know of the issue and I believe all updates after will have the message showing, it is just the last one that they were not working correctly on. Mistakes happen and this one happened with Foundation. I could be wrong about where the mistake is, but I believe I am right.