Error: "MetaMate: Couldn’t obtain plugin principal class", How to solve?


(Neil Barman) #1

Hello,

I just ran RW7 (7.1.7 to be exact) for the first time in a while and received the error message:
“MetaMate: Couldn’t obtain plugin principal class
Would you like to check for updates?”

I press the “Update Plugins” button and, as far as I can tell, nothing happens. If I quit and re-run RW7 I get the same message. What does it mean and how do I solve it?

(For what it’s worth, I have also updated to the most current version of RW7 and I am still getting the message.)

Thanks!
-Neil


(Robert Ziebol 🖖🏼) #2

MetaMate is not updated to work with RW 7, and it will not be ready for a while.


(Neil Barman) #3

Good to know… Should I just ignore the error message in that case?

-Neil


(Robert Ziebol 🖖🏼) #4

I would remove it from your addons for now.


(Neil Barman) #5

Will do. I actually don’t see it listed in the “Manage Addons” window of RW7… Is there another way to remove it from within the application, or must I do it manually (ad if so, where do I look for it)?

Thanks,
-Neil


(Matt Vranes) #6

@NeilB – I had this same problem with CodeComplete and MetaMate in Rapidweaver7. Here’a link that helped me find how to access and delete those manually:

https://kb.realmacsoftware.com/article/16-how-to-manually-install-add-ons

Ultimately, I pressed command + option + 7 and it opened right up. Hope that helps.