Error on opening document

I’ve spent a couple of days re-learning RW after a lengthy break.

Today I opened my file and was presented with an error - Notice : file_get_contents(): read of 8192 bytes failed with errno=21 Is a directory in /Applications/RapidWeaver 8.app/Contents/Resources/RWWebServerLaunch.php on line 178

I dug into the file in question and it seems related to blog posts. I have no blog posts in the file. I can open the file in edit mode but it generates the error when previewing.

On the problematic page I removed everything except the menu bar and the error disappeared. I’m happy enough I can work again but concerned I might be making complex pages and suddenly need to delete them and start again.

Can anyone shed any light on this error and potentially a way to avoid it?

Many thanks.

I’m not at a Mac right now, so I can’t check, but what might make you think that a file called RWWebServerLaunch.php is only for blog posts?

Anyway, since you have no blog, and you didn’t say what kind of page the “problematic page” is, or what was on the page that you removed, it’s really hard to say.

Do you have a copy of the project file before you removed everything? If you do you might be able to figure out what exactly caused the problem. If you don’t then it’s going to be difficult to determine what caused the problems.

Interesting, I’ve seen it a couple of times today and I think I might have identified the issue.

If I open the file from the recent items menu I get the error. If I open the file by double clicking in the Finder I don’t get the error. There may still be something specific to my setup/theme/stacks but so far this seems fairly repeatable.

Are you sure that the recent items menu is pointing to the same file? What’s appears in recent items is controlled by macOS.

You can check the full path name of the project you open by simply right-clicking on the project icon at the top of the window:
2021-09-12_06-09-29

I would doubt that opening the same project file by double-clicking or opening from recent would change the way the preview works.

2 Likes

It has happened from both the OS recent items menu and the Rapidweaver recent items menu (which I assumed is managed by RW). It doesn’t appear to happen if I have just restarted RW. My guess would be the recent item alias is not being resolved properly.

I’m not trying to strictly track the issue but I am trying to note when it’s occurring. A quick Google search suggests I’m not the only person to have seen it. As a programmer myself I can understand how annoying intermittent errors can be.

No it’s not managed by RW.

It’s just a different display of what macOS has stored.

As I outlined above, you should be able to check the path of the “bad” file that you opened with recent items against the “good” file that you opened by double clicking in finder.

Not sure what you searched for, I just checked Google (which I never use), DuckDuckGo and Bing and can’t find anything like this, at least not specific to RapidWeaver.

Hears some of what I searched for:

  1. “RapidWeaver error on opening file”
  2. “RapidWeaver open wrong document”
  3. “ RapidWeaver error on opening document”

It really doesn’t appear to be a problem for the majority of RW users, so I don’t think it’s a RW problem. There’s thousands of RW projects being opened everyday, and this is the only report I’ve found like this.

My guess is that it’s something unique to your setup.

1 Like

Thanks for your response but you seem to be getting upset I’m raising it - please don’t shoot the messenger. Here’s a couple of examples after googling the error message.

example of 187 error
Same error here. The site has been shut down although can be accessed via cache
and a similar one here - RW8 Bug in Photo Album - #4 by TatoSoftware1

It’s an intermittent problem which may well be specific to my set (as I said previously) but that doesn’t mean it doesn’t exist.

It’s not the theme (I tried a different theme), it’s happening with multiple files and restarting RW doesn’t totally eliminate it. This was from my first launch today opening from the Finder:

Closing and re-opening the file has resolved it this morning. The file which opens is definitely the correct file. I haven’t seen it happen when the file is closed in Edit mode.

For the record I’m on a MBP running Big Sur 11.5.1 and RW 8.9.1

I also got the same error today for the first time. I opened my RW file in ‘Preview’ mode, and was presented with the same error. If I then changed to ‘Edit’ mode and looked at the page it seemed OK, but not in ‘Preview’.

Ultimately the offending page started working correctly in ‘Preview’ mode after I clicked away to some other pages on my site and then returned. At the moment, it all seems to be working.

Which page type are you using for the pages this error happens in preview?

If it is a stacks page, which stacks are on that page?

For me it’s a stacks page using Photo Pro and Font File stacks (although it was doing it before I added the Font stack). I think I have also seen it on pages without the Photo Pro stack.