Event Calendar stack: Google calendar won't display. API key problem?


(Ann Powell Groner) #1

Hi. I have just purchased the Event Calendar stack from Chr. Richardet and I can’t get the Google calendar to display. Not in the RW client or in the published page. I see absolutely nothing, not a border or background color - nothing. I added the stack on a separate page using the inline option and that displays correctly. So it’s only the Google option that doesn’t work.

I’m positive that I have entered the correct Google calendar id and that I entered the API key correctly. I have made sure that the Google calendar is set to “make this calendar public” and I can see the calendar in an iframe. Others can see the calendar so it is publicly visible.

This makes me think the problem is with the API key - ? I followed the instructions to add a project, then a credential, selecting API key. It gave me a warning that it was unrestricted. I ignored that at first - and during troubleshooting decided to enter my domain into the area for allowable referrers. I find it odd that in the Dashboard section of my project on console.developers.google.com nothing is showing. It says I have no API’s enabled. I can’t seem to see what steps I have failed to take to get the API key to work. Any help? Thanks in advance.


(Jason Bostick) #2

What else is on the page? I had an issue with it not showing up and it was because of a javascript conflict and the order in which I had two different stacks.


(Ann Powell Groner) #3

Nothing else is on the page. I tried with a variety of themes and a blank theme to check for the issue you suggest. I’m pretty sure it is an API key issue but who knows. Thanks for the suggestion.


(Jonathan Spencer) #4

I just tried the stack and used the default Google calendar with the developers API key and it did display the calendar but there are no events to show. Have you tried the default settings just to see if it shows the calendar? I have had problems with conflicts as well in the past.


(Jonathan Spencer) #5

I just tried one of my Google calendars with the developers API and it worked just fine.


(Ann Powell Groner) #6

When you visit your Google API developer dashboard, do you see nothing (like I do) or does it say that your API is enabled? I can’t help but believe my problem is with the Google API not being enabled but I can’t for the life of me see how to enable it.

Here are two screenshots - perhaps you can see what’s missing?


(Jonathan Spencer) #7

Yes, I have the same. I am using my API key from the Credentials page just like you have! Strange! Have you tried the developers default in the stack?


(Ann Powell Groner) #8

UPDATE:
The Google calendar now works fine. Once my original problem (bad API key) was fixed, I then began to incorporate the calendar into my site. It fails inside a Foundry Card stack. I’ll move my issue to the Foundry forum. Thanks so much for your help


(Jan Fuellemann) #9

Put it to: http://discourse.elixirgraphics.com and let @Elixir know :slight_smile: