Exception while exporting site - need to convert colorspace


(Lutz Cleffmann) #1

Today after just having changed a link on one of my pages, I got following error message:
33

Where can I look for the reason?


(Lutz Cleffmann) #2

I just tested it with an old unchanged version of the project which uploaded without any problems in the past and got the same error message.
Fortunately the site is still up and running here: https://vor-ort-foto.de, but I need a solution.


(klaatu) #3

Hi

I don’t know what colorspace is, but going by the error message my guess would be that somewhere (possibly related to whatever you changed) is going wrong in the color definitions or conversions. Different color systems such as RGB, RGBA, Hex or the one mentioned in your message CMYK take different values for each of the elements that make up that definition,

Eg A value for the red (as in R in the RGB), a value for green ( as in the G ) and so on. My guess is that an incorrect value is being used, or perhaps calculated, at export/publish time, I would look for any mistakes or errors in the values used in theme/stacks/plugins which might be getting trapped and resulting in this exception. It can be very easy to paste colors into fields, for example, without realising the field is looking for a specific format.

Note that there are some issues with your published site - CORS policy errors and mixed content. Might be worth a quick look in the console to see what I mean.

While looking around for what colorspace might be I landed on this site:
https://mycolor.space/

Thats a fantastic resource! You can never have too many palette generators. Nice one.

Good luck


(Doug Bennett) #4

Other than what @klaatu suggested,
Have you contacted Realmac support yet?

The reason I’m asking is the error message contains the NSColor in the message, and appears to be a very ambiguous generic message. Most messages that contain that capital NS In the message will often require their support as they’re internally generated messages.

They probably will need the project file (a link to Dropbox type of file) and a reference to this post.


(Lutz Cleffmann) #5

We are in contact with Realmac support. I hope, they can help.
On their advice we have tested the latest build of 8.1. There the project doesn’t even start to export as well as another project we are running.
We have uploaded the project files for them to look into them.
Hopefully we will get an answer soon.
Regards
Prodrive


(Peter Danckwerts) #6

I cannot see the image you posted but @klaatu is right. Colorspace refers to one of the various colour systems used to reproduce colours. You should never use CMYK (Cyan, Magenta, Yellow, blacK) images for the internet. It is the colorspace used for printing and consists of pigments, whereas RGB (Red, Green, Blue), Hex, etc. mix the primary transmitted light colours to create the desired hue.


(Lutz Cleffmann) #7

If there is a CMYK element in our project this might have happened by accident. I will check every single graphic element for that.
Anyway, everything worked fine for a long time and nothing has been changed with the project containing any color information. With the beto of 8.1 it is totally blocked without any error message. So I assume that the reason is somewhere in the latests builds of RapidWeaver or Stacks.


(Lutz Cleffmann) #8

I have now checked all images on the project and there is no single CMYK image.


(Peter Danckwerts) #9

Well, NSColor Generic CMYK is a colour space used by Objective C. That seems a very odd thing to be cropping up.


(Isaiah Carew) #10

This is not a user-fixable problem. It’s a bug, probably in one of the plugins you have installed.

Check to make sure you have the latest versions of plugins from YourHead and Foreground. If you have LogHound plugins installed you’ll have to update manually. See here: LogHound plugins Moved to YourHead

If that doesn’t help, try removing your plugins one at a time until the problem goes away. When you find out which plugin is the culprit, contact the developer (OK, it’s probably me – :wave:Hi, I make a lot of plugins) and share a copy of the project file with them (me). You’ll probably need to zip the project up and share it on dropbox. You can find the links to our support email at the bottom of every page of the yourhead.com site. On the off chance that it is one of the other developers, contact those guys, they may alredy be working on a fix.

Let me know what you find out,
Isaiah


(Lutz Cleffmann) #11

Hi,
the problem is fixed with RW 8.1.3.
So I don’t need to chase other reasons any more.
Thank you all for your support.
Lutz


(Isaiah Carew) #12

Oh that’s great news. I’m glad to hear it too. I’ll scratch that one off my to-do list. Thanks for reporting back. :slight_smile:


(system) #13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.