Publishing problem: "Exception while exporting site"


(Peter Laundy) #1

Looking at previous posts at new RW updates, this appears to be a bug that happens at RW update time.

In RW 7.1.0, in a file that was begun in the previous RW version, I am getting this error whenever I try to publish the site. Here is the detailed message:

-__NSCFString characterAtIndex:: Range or index out of bounds : Range or index out of bounds


(Peter Laundy) #2

The fix listed in the data base does not work. None of the following have worked:

  • Closing and reopening the file
  • Saving as a new version of the file
  • Closing and reopening RW
  • Shutting down and starting up my Mac.
  • Installing the 7.1.1 update and doing the above.

(Dan) #3

Hi Peter,

Can you email us your project file so we can see if we can re-create the problem here - if we can re-create it, we should be able to fix it!

Email support@realmacsoftware.com and include a link to this thread.

Cheers,
Dan


(Giorgio Zamariola) #4

I updated to RW 7.1.1 today. It crashes one second after I press PUBLISH. It happens on projects I published successfully by RW 7.1.0 on last days. Restarted MB. I cannot publish anymore. Please Help!


(Dan) #5

We should have a new build (RapidWeaver 7.1.2) out later today that fixes this and more, so sorry for the troubles.

In the meantime, you can downgrade to RapidWaver 7.1.0 from here:

Cheers,
Dan


(Giorgio Zamariola) #6

OK, Thanks, Dan! :relaxed:


(Peter Laundy) #7

OK. Will do. Some more info for you.

The problem seems to be that Rapidweaver thinks the Foundation Theme is missing. And it is occurring not only on this file, but on new files I generate. I am getting the “Exception” message and file crashing when I try to go to Master Styles in this file, and any new file I try to open. And am getting messages on opening files that “Foundation Theme is Missing” and Rapidweaver will therefore install Foundation. When Master Styles does open the area it opens is blank except for a dropdown with default theme chosen but no other options in the dropdown.


(Peter Laundy) #8

Dan,

Will you be posting here as to whether you’ve been able to re-create and fix the problem?

Just wanted to make sure you understood the problem not only happens with this particular file, but also with any new file created with 7.1.0-7.1.2


(Giorgio Zamariola) #9

UPDATES about RW 7.1.x crash while exporting site before publishing

  • Downgraded to 7.1.0: same problem
  • Upgraded to 7.1.2: same problem
  • When I press the PUBLISH button or RE-PUBLISH ALL FILES, RW always crashes on different random files
  • Same problem on different project and different hostings

Finally I was able to update my sites by CTRL-click to PUBLISH EACH PAGE BY ITSELF with its sub-pages

When I edit a very little number of pages, the PUBLISH button usually works.

It looks like RW crashes when it’s going to export higher volume of items and it always crashes 2-3 seconds after pressing the PUBLISH button.

It’s very frustrating, I hope those info might be helpful.
Thanks!
Giorgio


Round of crashes exporting or publishing on 7.1.x (Solved 7.1.3)
(Giorgio Zamariola) #10

OK - Updated to RW 7.1.3: no more crashes, it works fine.
Thanks DAN!


Round of crashes exporting or publishing on 7.1.x (Solved 7.1.3)
(Christopher) #11

Hi Dan,

I see here that this issue is reported as having been solved with 7.1.3 but I’m experiencing the same issue on 7.1.5 with one project file only.

Steps to reproduce: Clicking “Publish” results in “Unable to export” with the error: “-[__NSCFString characterAtIndex:]: Range or index out of bounds.”

Steps taken so far trying to resolve:

  • Tried publishing one page only.
  • Tried restarting Rapidweaver.
  • Ensured that all stacks and plug-ins were up to date.
  • Tried removing Pluskit.
  • Tried reinstalling latest Foundation theme.

I am able to publish a small non-Foundation themed site but not a biggish Foundation themed site.

Any help you can offer is greatly appreciated.

Christopher

Update: Same issue as above with 7.1.6 and 7.1.7
Update 2: Downgraded to 7.1.3. Same issue.


(Dwayne Rourke) #12

Using RW 7.1.5 I am getting an “exception while exporting site” error message with the following details: -[NSURL initFileURLWithPath:] nil string parameter.

Anyone have suggestions as to where I need to to go from here?


(Dan) #13

We’re looking into this issue now, but it appears it’s caused by the “Minify CSS and Javascript” option in RW in conjunction with using the Foundation theme (cc @joeworkman).

For now just switch off the “Minify CSS and Javascript” option under the advanced general settings. and your site should preview and export just fine.

If it’s an RW issue, we’ll get an updated shipped asap.

Cheers,
Dan


(Sascha Krüger) #14

Minify CSS still needs to be turned off with 7.1.7 on Sierra, otherwise there is still the error “index out of bounds” when publishing.
Will there be any release to finally fix that?


(Dan) #15

Yup, the next release should fix this issue. Sorry for the delay.


(Peter Laundy) #16

Unchecking “Minify CSS and Javascript” worked for me.


(Christopher) #17

Worked for me, too. Thanks, Dan!


(Edward Anderson) #18

I am experiencing the same problems today - Exception while exporting the site - RW also crashes when trying to publish and or trying to export.

Error message reads as such:
*** -[__NSArrayM removeObjectsInRange:]: range {2, 1} extends beyond bounds [0 … 1]

RapidWeaver Version 7.1.7 (18375)

Any assistance is greatly appreciated.

Cheers

Edward


(Ollie Pryer) #19

Same issue as above. Cannot export any site, I’ve unchecked Minify CSS and Javascript and also tried older versions of Rapid Weaver none of which work.

I don’t get any error message on screen apart from ‘Rapid Weaver closed unexpectedly’ send report etc…

Rapid Weaver Version: 7.1.7 (18375)
MacOS: Sierra, Version 10.12.1


(Craig) #20

I just had this issue with in RW 7.5.1.
RW error
I have a fully published operational website that I only made some tweaks to last night and now it won’t publish. Minify CSS was already turned off, so that solution did not resolve anything.

I have read the thread and I am trying to publish one page at a time. This works. BUT, after I went down the whole list of pages and finally got to the Sitemap page, when I published that, it put blue dots on all the pages I just tediously uploaded one at a time and now I am doing that process all over again. Anyone else doing this, I suggest you start with the Sitemap page first before uploading every other page.

SIDENOTE: Why does the contact page have 158 elements that have to be uploaded when all my other pages average around 20 elements? That seems excessive for such a simple form page.

After doing publishing each page seperately, I saved the file, then made a copy. I made minor changes on the copy and did a regular full publish of the site and it seemed to work normal.

I also use Meta Mate stack. Making a change in Meta Mate prior to publishing last night might have caused this error, but I am not sure. I just made a change in on a page in Meta Mate which affected all the pages, causing me to do a new full upload, but no problems. The full site uploaded.