Extra Content Not displaying correctly?


(Simon Palmer) #1

Hi Folks,

Using Multi Lode Theme which has worked handsomely for me. But, I’ve just had an error crop up. I’ve moved the site to SSL, which has been fine, however, it seems that the Extra Content areas are now no longer displaying correctly on the live site. Looking in RW, the EC3 area displays correctly and opens correctly, but now the little newsletter signup form is displaying in the body of the page?

Looking at the Dev console, its telling me that it cannot find the JS files.

I looked at the permissions and the rw_common folder had 700, which I’ve tried to reset to 755 as per another thread on here. Still no joy.

Anyone have an idea of what I’m either doing wrong or not done?

Link: www.thehorsephysio.co.uk


(Doug Bennett) #2

It appears you have some files loading that are coming from HTTP, not HTTPS. Fonts and a jquery.
Don’t know if that is something that came with the theme or something you added?


(Simon Palmer) #3

The fonts and the query all originate from the theme


(Doug Bennett) #4

Not familiar with that theme but some of the files are being blocked ,

Looks as though you have redirects going to https:// for http:// thats good but if it is something you can turn off easliy might help you determine if this is SSL only problem. If you can turn that off then check with just http:// and see if the problem is still around.
You can also check your URL with a tool like:
https://www.whynopadlock.com/index.html
If the problem only occurs in SSL (https://) this will help you id the files that might be blocking on load. I know most are in the theme or stacks but testing this would confirm what is causing the problem.


(Doug Bennett) #5

In google chrome You get an unsafe warning:

If you click on the red box you get this:

If you click on the load unsafe scripts you get the load of the page I think you are expecting.

Again this would have to do with loading http:// files and not https://.

Might have to do with what your using for the toggle box?


(Simon Palmer) #6

I’ve tried modifying the htaccess hidden file on the server but that hasn’t helped.
This was the script in it:
RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://thehorsephysio.co.uk/$1 [R=301,L]

Is the above correct or having I screwed up?
Cheers


(Doug Bennett) #7

No that looks like what you want. As you can see while you were looking at that, I tested on Chrome. Chrome lets you force load blocked content, and the toggler was back in place. Don’t know what you are using for the toggle drop-down?
Once you force load it tells you not secure.


(Doug Bennett) #8

I think this is the problem file:
http://ajax.googleapis.com/ajax/libs/jquery/1.11.0/jquery.min.js

That would need to be changed to the https:// version so I would contact the theme developer.


(Simon Palmer) #9

Doug, thanks for this. I have logged a message with Mulitheme who make Multi Lode. So, I’ll come back on here when I get a response and update. Hopefully a solution!
Cheers and thank again for your enquiring mind!
Cheers


(Doug Bennett) #10

Yes, the problem with changing the htaccess file is your using a r=301(what you want after testing), but they get cached. SO I would set it back.