What happened to my ExtraContent stack?


(Gary McAlpine) #1

Hi there! I have a puzzling glitch and I’m wondering if anyone else has experienced this and can perhaps suggest a fix.

I built a large website (about 60 pages) in January this year. The theme is HV-Rainbow and I think I used stacks v2. I have since upgraded to Stacks 3.0.5 and I also upgrade the theme using Waterfall. All 60 pages use the ExtraContent Stack (I used the original Stack - the one with the green arrow icon - see image). Now when I open the web project the ExtraContent has been replaced with “Template” and the stack elements within it are still there but not where they should be in Preview (see image).

Using Time Capsule I have restored the project file and the Theme version to the original when the site was built in January. I also restored to the earliest version of Stacks 3. All this did not solve the problem. I then tried to restore back to Stacks 2 but RW did not recognise the pages.

It’s going to take me several hours to rebuild all the lost content on this project and I’d appreciate any suggestions. The theme developer has been very helpful but he cannot replicate the problem. My hunch is it’s a problem with the old ExtraContent Stack and Stacks3. I see there a newer ExtraContent Plus stack by Stacks4Stacks which I can manually replace in all 60 pages but it’s very frustrating to have to do this and quite time consuming.

We upgrade in good faith but sometimes I feel upgrades are released before all the bugs are ironed out.

Cheers,
Gary



(Rob Beattie) #2

Hi @Garymac - if you go here - http://foss.seydesign.com/?p=ExtraContent - you can download the latest version of the ordinary ExtraContent stack for free. Install that and you should be good to go.

Rob


(Gary McAlpine) #3

Hi Rob,

Many thanks for this. Problem solved :slight_smile: I guess some of these older stacks I have don’t have the automatic update feature. That saved me a good chunk of time. Much appreciated!

Cheers,
Gary


(LJ) #4

I just downloaded but tried to install and it failed every time? Any known issues?


(Gary McAlpine) #5

I got a “Stack installation failed” message when I double clicked on the newly downloaded stack so I manually placed it into the appropriate folder and that worked OK;

~/Library/Containers/com.realmacsoftware.rapidweaver6/Data/Library/Application Support/Rapidweaver/Stacks

Cheers,
Gary