FIX for Add-ons (and Stacks) Not Updating

Since it’s that time of year to make new year resolutions, I figured I’d make one to start posting the fixes to common and even rare issues we encounter. Knowledge is power, right? :smiley:

After macOS High Sierra, we’ve had a handful of reports where plugin updates were not “applying” in RapidWeaver.

Scenario: A user would see the updates, follow the prompts and install them, but the same updates would appear again. Because the updates for plugins and add-ons (such as stacks) would not apply this would result in an endless loop of the same updates.

The fix we’ve found is to reestablish permissions for your add-ons folder. Since there are no “repair permissions” in recent versions of macOS, there’s a different method now.

How to fix the plugins / stacks not updating issues

  • Step 1: Go to RapidWeaver, press and hold the Option (alt) key - select "Reveal Addons Folder"
  • Step 2: Click anywhere (whitespace) in the folder. Press Command + I on your keyboard.
  • Step 3: Unlock the Sharing & Permissions options by clicking on the padlock and entering an admin password
  • Step 4: Set your user to Read & Write access, then go to the gear/cog icon and select “Apply to enclosed items…”
  • Step 5: Re-open RapidWeaver and update your add-ons as usual

If the issue still happens to occur, do send us an email directly at (click to reveal): [spoiler][/spoiler]


Thanks! I’d like to add: in case you’ve placed your RW addons folder in your dropbox (as I have in order to sync it with both my machines), wait for the synchronisation to be finished (you can identify synchronized objects by the green checkmark-sign and unsynchronized ones by the blue circular mark, see screenshot).
It may take a while once you’ve hit “apply to enclosed items” for Dropbox to synchronize, but that should be done before you retry opening RW.stacks

1 Like

This is a great point - thanks for sharing! :ok_hand:

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.