Font issues with Instacks CustomFonts

Firstly…thanks to Michael Mitchell, Doug Bennett and Don H. I now have 2 fully updating and fast websites.

I now need to solve font issues using local fonts. I’m using Akrobat font for which I have used fontsquirrel to create web usable ‘woff’ etc files. These I have put into a resources folder.

These all work perfectly in RW8. When I publish my 2 websites I get exact renderings of the fonts in MS Edge and Google Chrome…at least on the iMac I created the websites on.

Safari perversely doesn’t recognise the fonts at all…even on my iMac. ? What’s that all about ?

On other devices the fonts don’t work.

I appear to be doing something right to get MS Edge and Chrome to use this font quite happily…although I realise they are reading my native fonts.

I am using only Akrobat Bold throughout…(except for Akrobat Black in the Foundry set-up…for Gallery 3 which I use).

Any pointers? I regret Instacks CustomFonts tutorial isn’t very helpful.

Ron H

Are you using Foundry for these sites? Have you setup Typeface using a local font from RW resources? Here’s the documentation on it.

Do you have a URL to show us?

These are the URLs www.

I attach a screenshot from pictographix home page off MS Edge (on my iMac). This is exactly what the website should look like. I assume though that MS Edge is picking up the native fonts here.
Safari however doesn’t recognise the font(s) at all even on this iMac.

The web fonts (created via fontsquirrel) are in RW8 resources as required. I am only using 2 weights throughout… bold and black of a font called Akrobat.

I apparently am not being allowed to send you any links. ???

I also tried to attach a screenshot of the correctly rendered page off MS Edge on my iMac…but that is being treated as spam advertising.

Seems I might be stuffed

I am using Foundry…and Instacks CustomFont. Webfonts I’ve created via FontSquirrel are placed in Resources in a folder.

Each place I use the Custom Font stacks I set up local fonts and use (in this case) Akrobat Bold. It seems to work.

I am confused what Typeface is relevant to here.

When using non-native fonts on a web page, you need code in the page to tell the browser to download the font file and to let it know what name you use to refer to it. If you do not have that code, then only computers that have the font installed on their computer will render the text in that font.

Foundry’s Typeface stack allows you to use custom fonts (Google, Adobe Typekit, System or Self Hosted). It sounds like you want to use a self-hosted font.

I don’t have Instacks CustomFont, so maybe it does the same thing and is just setup incorrectly. If if does not load and slow you to use set-hosted fonts, then you need something that will. The Typeface stack, included with Foundry, does this.

Does it really work? I thought your post was because it doesn’t work.

1 Like

Dan…thanks for taking an interest.

When I say 'it seems to work" I mean within RW8

This is a section of the CustomFont tutorial which baffles me. Any chance of getting this into plain English ? I have put the web fonts into resources.

" ### Integrate the Fonts

The fonts must be integrated into the resources area of your RapidWeaver project. Create a folder with the name fonts (case sensitive) underneath the resources area, and insert the 4 different files (eot, woff, ttf, svg) into it. In order to simplify, make sure no spaces (blanks) or special characters are inside the file name. All 4 files need to have the same name (beside the file type extention). For reference, see the first of the setting pictures. Drag and drop the Stack into your page. As Font Family Name, use the file name (case sensitive), without the file type extention.

Change the font of your title, slogan, footer, and even navigation bar

In order to change the font of title, slogan, footer, and navigation bar, the text of these fields has to be sourounded by span tags with additional font-family settings. This can be done in the Page Inspector or general settings of the project. See the third screenshot in the settings and the demo page for reference."

I have lost overview what’s your detailed problem now.

So: what is still not working?


I am trying to use only the one typeface in just 2 weights. Namely : Akrobat bold and Akrobat Black

I have converted the original font to web versions using fontsquirrel. I have put these webfonts into RW8 resources.

In RapidWeaver these webfonts perform exactly as I want. They also perform perfectly in Google Chrome and MS Edge but of course only on this iMac. Safari doesn’t recognise the fonts at all.

The CustomFonts tutorial is a bit sketchy. I am missing something but I know not what.

Ron H

You are referencing the fonts for example with the name

acrobat bold

On your server, there aren’t no acrobat bold files.

Not available

That’s the same in Chrome.

Please review your uploaded files. I also suggest using no blanks in the font names.


I’d like to emphasise I am not a web designer.I don’t know how or where you got the screenshot.
This is just a one-off project to sell my pictures

What I have established is that I must be reading my original fonts in RW8 not webfonts :

I manually changed the webfonts to remove spaces. eg. AkrobatBold.woff2. I added these to resources.

Then on RW pages I refer to “AkrobatBold” in CustomFont boxes. They immediately default to Helvetica in RW.

So…it’s not reading webfonts at all.

What am I missing here? How do I get the RW pages to read the webfonts?


I don’t know what you are doing actually.

All I can see is that you now use Akrobat-Bold and none of these files are available on the server.

Please double check your publishing workflow and make sure the font files are correctly copied to your server.

This is the bit that baffles me.:

"Please double check your publishing workflow and make sure the font files are correctly copied to your server.”


I cannot see any way of doing either. I think I might have to admit defeat.


The font file aren’t being found.

But it looks like somewhere you changed the blank to a dash -. The files that are being looked for are Akrobat-Bold NOT AkrobatBold?

Without seeing exactly what you have it’s hard for you to get help.

Open a FTP application and check your folder content on your server.

In RapidWeaver the fonts being used seem to be the original fonts NOT the webfonts.

The webfonts in resources are currently (for example) Akrobat-Bold and Akrobat-Black. This is also the name of the original native font.

If I try to change filenames to AkrobatBold the text defaults to Helvetica.

I attach 2 screenshots of both scenarios.

Surely it can’t be this complicated?
The compressed version is the correct one.

Ron H

Please upload screenshots of

  • The files inside the RW resources area
  • Your web server where these files are visible in the correct folder

I am waiting for the webhost to advise where I can find the font directory.

Then start with a screenshot of the RW resources area.