Foundry Banner Style image missing after update to RW 8.7

A slightly strange one here.

The website is Cotswold Fireworks… Every background image inside the banner is no longer showing.

This is after updating to RW 8.7, allowing Stacks to update to the latest and Foundry to also process the update to v2.3.1.0. I’ve attached screens below that show the background image will display in edit mode but switch to visual edit mode and the image no longer displays which is also the same output on the live website.

and in visual mode

Have I missed something obvious? Maybe a switch incorrectly turned on?

/update/ - I have just loaded other projects and they show the same symptoms.



Nick can you send me your project file and let me know what version of Foundry you’re running?

Update: Looks like you’re running v2.3.1 so no need to tell me that. Just send over a ZIP file containing your project file to adam at elixirgraphics dot com

Also let us know what version of Stacks you’re using. And let us know if it is a beta as well, please.

So far I cannot recreate the problem here with my project files in RW 8.7.

One other thing. If you want to try something real quick as a test, can you select something other than “Image” as the “Banner Style” and then re-select “Image,” and see if that does anything.

While I wait to hear back from @Pyrobrit, can I ask if anyone else has run into this problem? I cannot recreate it here in my own tests.

Sorry I was in bed. Yes I selected something else and removed the image then added it back for the same thing to happen.

Stacks version is 4.1.0b24

Good morning @Pyrobrit

Just got your project. I loaded it up in RW v8.7 and everything looks A-OK here:

The difference between your setup and mine though is I’m currently using a non-beta version of Stacks.

So I downloaded and installed Stacks beta 23 and everything was fine there as well:

I then updated to Stacks beta 24, and that is when things stopped working:

So I believe that is the problem here. You’ll want to report your bug to @Isaiah so that he can look over it before final release. You’ll need to also provide him with your project file so he has something to test against.


The same happened to me with the b24 and I filed a bug report with @isaiah.


it sounds very similar to this bug:

i’m looking into it now. i suspect this is related to the ../ issues we’ve been talking about yesterday on the dev slack channel, but haven’t dug down deep enough to understand the issue quite yet.

but the background image is being published, it’s just that the path is incorrect. if this is another variant of the missing ../ i’m going to try to restore the v4.0 API behavior – whatever that behavior might be. my hope is that fixes this issue. if it doesn’t then i’ll let you know.



Many thanks. I have reverted back to the release version of stacks 4 from your website and that has fixed the problem. v4.0.4_4813



1 Like

This should be fixed in beta 25 (Release Candidate 1 – which will become the v4.1 release unless a catastrophic error is detected).

THANK YOU THANK YOU THANK YOU for helping us find this before we finallized v4.1. You’re a life-saver!!!

But in the future, would you mind reporting beta problems to the Stacks Slack channel?

The forum is great at surfacing old posts – which is usually great – but having this thread here will only confuse folks. :pensive:

Novice users will bump into this thread searching for solutions to other background image problems and for years we will be explaining that no, this thread was for a problem that only existed for less than 12 hours. :hourglass:

Thanks again!!! And get ready. Only 35 minutes to release time. :rocket: :partying_face: :tada:


To be honest I thought it might have been an 8.7 issue and not foundry or stacks but did notice that all three updated within minutes of each other.

I’ll try to be more aware next time :innocent: but many thanks for acting so fast on a fix. I’ll test it shortly.


No worries.

It’s always a bit of a jumble when a new OS version comes out and everyone is trying to get all their releases out. Sometimes it’s hard to tell what component update triggered the change.

But hopefully this one is all fixed.

This bug is actually a good story, so let me end this thread with how we, as a community of competing and cooperating developers worked together to fix this in a nice way.

Story Time!!! :open_book: :slight_smile:

We had a little discussion yesterday about this bug in our private developers’ chat.

The root of the problem is a Stacks v4.0 API bug. It’s not a big problem so Several developers have worked around that bug with a little patch.

Last week, thinking that only one developer had made this patch I went ahead and corrected the problem, and made arrangements with that developer to remove his patch at the same time so we didn’t over-fix the problem.

However it turns out that there were several developers who made similar patches. Oops.

So yesterday as a group we decided compatibility and a smooth transition was more important than correctness and the small corner case that the patch doesn’t cover. So v4.1 re-added the v4.0 behavior.
I should say, not every developers was 100% on board. Correctness does have its merits too. But I think I managed to herd all the cats together for a consensus. :tiger2:

Once an API is out in the wild it becomes written in stone. Fixing the bug would hurt more things than it helped. It would cause real problems.

We will, as a group, migrate together to v4.2 where we’ll fix the bug the right way, but we can allow developers to opt-in to that new API when they’re ready. And when everyone has opted in we can deprecate and eventually remove the old function.

It takes a little more effort to manage API transitions smoothly, especially in a group that’s not always of one mind, but I think it’s worth it in the long run.

End of story time. :blush:


@isaiah a little off topic but I had to say it

You are the best. Love how you work to be in consensus with others and find a way to help developers and clients/users (=me).
Great job: three upgrades Apple/Rapidweaver/Stacks in one package.
Still on Os 10.14.6 ( have my reasons/software) but good to know to be prepared for actual OS’s.
Looking forward to work with RW and Stacks to make my clients and me happy.
Keep up the good work.


Many thanks for all the help you and the other developers put in. I can confirm that b25 also works fine and created the correct files for the website.

Cheers! :beer: :beers:

I should also mention that raising this topic has also put me in touch with a like minded person in the fireworks industry who lives close to me and happens to be a rapidweaver user too. Now that is good positive news in this pretty awful year so far.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.