FTP connection issues RW8

RW 8.6.2

I cannot get the internal FTP to connect to my server. We just migrated to a new server and we are using a VPS.

I can connect using FileZilla but the internal ftp client will not connect. My settings are absolutely correct. Hosting has sleuthed out that this is a RW issue and not “us”.

This article

The last paragraph says:

FTPS Connection Settings
When publishing using FTPS, there are several different modes that web hosts can use to authenticate you. As apps cannot reliably detect the necessary FTPS settings when publishing, you may need to try the Use SSL for menu options before you can successfully publish.<

well… no. for the life of me I cannot find the SSL menu options.

I tried everything in the article.
I tried FTP / FTPS / SFTP all to no avail.

Sometimes it says I cannot connect and some errors it say wrong info. Wrong info is anything other than SFTP

I need to be able to publish frequent updates. Any help would be appreciated. Hosting is stumped.

Without more information it’s going to difficult to get help.

  • Who is the hosting company
  • how are you wanting to connect, you are quoting things about FTPS, you also tried FTP/ FTPS/ SFTP, how are you wanting to connect?
  • How did you connect with FileZilla?
  • Screenshots of the publishing settings(RW), the Site manager settings you used to connect with FileZilla and the Error message you are getting would be helpful

I use SFTP for everything. It in my opinion is the most reliable. If you are using a VPS and are managing it yourself you will be using it anyway. FTPS is okay, but needs two ports and often gets blocked by firewalls.

OK stand by for screenshots. Totally slipped my mind.

I’m going to give you a screenshot of a side by side with the credentials from RW form and Filezilla.
I know they work because i did manage to transfer over from saved files with filezilla.
SFTP is preferred.
I am using Knownhost for my hosting and DirectAdmin is now my hosting panel.
Sometimes it says I cannot connect and some errors it say wrong info.
Wrong info is anything other than SFTP

Looks like you are using port 2200 on Filezilla,.
In RapidWeaver to add a port number you add it the traditional way to the host address with a : preceding it:
Server

redrum.me:2200

Change that and try the Test Button.
If the test works then I’d clear out the path in rapidweaver and hit the Browse button and select the proer directory.

I realize @teefers is responding right now, probably with better info than I can supply.

I notice the length of your two passwords is different. Potential problem?

teefers… we already tried that and I tried again just now.
Pretty much the same error but tells me creds are not correct. They are.
the path you see is “grayed” out. It’s “waiting” for me to put in a path. YES I have tried several paths to the directory to no avail. Same thing. Won’t connect or it’s saying wrong credentials.

both passwords are absolutely correct. Thanks.

I got this from hosting regarding passhprases. Should I give this a go?

I usually don’t bother with a passphrase on my keypairs, it’s not risky as long as you make sure that your private key is always kept secret and secure.

It’s safe to transmit the pubkey, though. That would go in /home/xxxxxxx/.ssh/authorized_keys

If you can generate a keypair to use with Rapidweaver, we can help put the pubkey in /home/xxxxxxx/.ssh/authorized_keys and make sure the perms are set correctly. It needs to be 700 for the .ssh dir and 600 for the authorized_keys file.

If you are getting the error on the test button, Then it’s usually the credentials, If the SSH is setup to use a passphrase than you will need to enter it. I don’t use them myself.

Rapidweaver should be using the same .ssh/ directory as FileZilla does. And it should be using the same known_hosts file in that directory.

If you are okay with a terminal you can generate a key_pair, you probably already have them.
You can check in the terminal:

ls -al ~/.ssh/id_*

you should see a pair of files:

The /id_rsa.pub is the one they want.
NEVER Share the id_rsa File with anyone.

If you don’t have those then you need to generate them:

But as I said for me RaipdWeaver, Transmit and FileZilla all use the same ~/.ssh/known_hosts file for SSH.

1 Like

well this was a giant fail. Followed your guidline and hosting and I see the files but how do I get them?
This is frustrating and my login inf is EXACTLY the same as Filezilla so I have no idea why RW won’t connect when FileZilla does with ease.
Can I publish to a local folder and then just upload through Filezilla? I would rather not, but I’ve been at this all day and I need to walk away for the weekend. My sites are up and I’m fine until Monday. I wish I knew who hacked my old server because at this point I want to wring their neck. This is way beyond my capabilities and I feel like I’m running in circles.

Should be no problem.

In Rapidweaver you can save the settings if you want first (they aren’t working right now but you can book mark them if you want).

Then under publishing method choose Local Folder (I’d change the name as well).
2020-06-27_12-32-36
Then select Choose Folder…
2020-06-27_12-35-17

Now the Dialog will appear important select an empty folder or select New Folder the first time.

You can place this anywhere you want, you will need to know where you put it for FileZilla.

Now select publish all files.

On FileZilla on the Local site (usually on the left side) navigate to the folder you published to on the Mac.

Connect to the host On should appear on the right side.

Make sure you are in the correct directory and select and drag the files over. You can also do a ⌘Cmd+a to select all, and right-click to add to the Transfer Queue.
Just make sure you ‘Toggle’ The transfer queue:
2020-06-27_12-47-21

Thank you. THAT is the one thing I figured out how to do while playing around.
I would just rather publish through the program, but I need to walk away for now, like I said. I’ll pop back Monday. All the help is appreciated.

Not sure how you are going to get them to the host company.
You can find them in finder if that helps.

Go to the go menu and go to folder (⇧Shift+⌘Cmd+G).
enter

~/.ssh

in the folder name.
2020-06-27_12-51-25

And you should see them.

I FIXED IT! WOO HOO and yay for me.

OK this is the issue… this program cannot use the root account. I remembered this morning ( a few minuets ago) that ONE site on the server works with this program - Shiftyandthegears.com

So I checked the credentials for that site and it’s using an ftp account I made specifically for that site. IT WORKS.

So I went to BadWolfDesigns.net where this issue is going on and I created an account for that site and tested it. IT WORKS NOW!

So for this particular program, the solution is to make an account for each domain and browse to the correct location to upload. DONE.

I cannot see any other way and as long as it’s working I’m satisfied. PHEW!

So we’re good. Well, we’re good until some other gremlin decides to test my [lack of] skills!