FTP problems uploading


(J Boudreau) #1

I have noticed a problem that I am experiencing uploading my sites and I am not sure what app is causing my grief. I am using High Sierra and RW 7.5.5. I do use little snitch to “control” my connections. I launch RW and allow port 80 and 443. I did have a window requesting always access to my site via keychain which was granted as always.
I publish my site and it does eventually time out on connect. I did a test the connection within the Publishing pane and it would time out too. This was never a problem with earlier versions.
I found that when I allow access to port 21, RW on little snitch the site loads with no problem. This is stopgap solution as I do not like opening up my system, especially involving FTP. Why is RW not requesting port access on publish? Is it a problem with keychain, Little Snitch, or RW?


(Doug Bennett) #2

Would need to see a screenshot of the RW publishing settings.
Also, the name of the hosting company might help.

  • FTP defaults to using port 20 and 21
  • default Port 443/HTTPS - web browsing (not FTP)
  • default Port 80/HTTP web browsing secure SSL (not FTP)

These could be configured differently by servers and firewalls.
If you’re concerned about security, you should switch to SFTP.
You can also configure RW to use a different port for publishing if the server is configured differently.
I doubt your issue is with RW, or keychain since when you open up little snitch things seem to work.


(J Boudreau) #3

Doug,
I am aware what ports 80 & 443 are for. I stated that these are the ports that I open on launching RW. The problem is why RW will not request access to port 21 on publish. I can publish with the settings as long at I create a rule in Little Snitch opening port 21 for RW.

The plot thickens
I just did some snooping and I have found “discrepancies” with my keychain. I also use 1Password and in the beginning of January, I changed my master password, along with many of my passwords. This seems to be throwing a wrench into my keychain access. I found that for me to look at some of my passwords in keychain, I had to enter my old master password to see the password in the record. Bizarre at best. I will be forwarding this onto Agile Bytes to see if they can give me any insight.
I have attached a screenshot of me putting in my password for access to the record in keychain. Keep in mind that I am the only user that has been on this mac and the password works on other records. There is another account “admin” that is a pristine account and is used strictly for troubleshooting. Root and guest are disabled.
I might get in touch with apple to find out the best way to straighten out keychain. I will keep you updated.


(Don H) #4

I do not believe there is a mechanism in OS X to for an application to request access to a port. An application requests access per se by opening a connection to that port. It’s up to Little Snitch to notice that an application is trying to open a connection to that port and either allow/deny/ask for approval.

You’ll probably have to contact Little Snitch’s developers as ask them why it is not noticing the port it trying to be accessed for RapidWeaver/ FTP. It’s been a long time since I used it, but maybe there is a rule outright blocking access to FTP (port 21) for security reasons and LS doesn’t present a request dialog to the user. LS may feel that for an insecure protocol like FTP, it’s better to always block it and let an experienced user manually setup a rule, if necessary.


(Doug Bennett) #5

Does it request or not request port 21? FTP will use both port 20 and 21 to publish by default. That’s why I wanted a screenshot of your RW publishing settings. What port are you wanting to use for publishing?
You can add a port number to your FTP settings by following them with a colon : and the port number. of course your host will need to be configured to use that port for FTP.

ftp.yourserver.com:23261


(system) #6

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.