FTP still a nuisance in RWC (switched to SFTP to fix)

After I don’t know when RW 8 came out, FTP has been a ongoing problem.
Even in RWC it still is a big nuisance. See movie, this is standard behaviour.

I always thought that RW woud open an FTP channel and upload all files and then close it.
But … I have found that, although it looks like a ‘global’ setting under ‘Publishing’, it actually is not. Each page has a key with the FTP-link in it, thus I think RW opens a new FTP channel for every single file, which, if that is the case, I find a bit simple.

And because of these ‘Failed transfers’, I can only use 1 file upload setting, instead of 6, because otherwise, the whole transfer is marked invalid, and you have to start to upload all 300 files AGAIN, instead of only the failed ones.

I am really vexed after all these years having to look at ‘Transfer failed’ 5s, 4s, 3s, 2s, 1s …

- -
Marc

2 Likes

Hey @MrMacvos,

So sorry to hear you’re having issues.

Does your hosting company support publishing via SFTP?
We’ve found this to be a lot more reliable if users are having issues uploading via FTP.

Yes, I have my own servers.
Where do I specify the port in the Publishing settings? I use a special port.

Try it like this, with the port on the end of the server address “:23261”

Great, it worked without connection errors. 1 connection or 6 connections, 250 files uploaded without problems. Thanks!

That is great to hear! :star_struck:

I have had similar issues with FTP and recently tried to enable the SFTP which my server does support. But ran into problems with the SSH keys required.

Alternately I have found that, using an alternate FTP application such as Transmit, by saving the site locally (great for testing) first, then using Transmit FTP works perfectly and very fast. It does check for file differences and only uploads changed files.

I suspect part of the different is where RapidWeaver I believe someone said opens the FTP access for each file. Transmit I open it and keep it open while I do the file compare/transfers until done. Not sure if this is it but I have noticed sometimes if I am experimenting with my hosting company and logging in multiple times quickly, there seems to be a time out - possibly a security thing? As mentioned, not sure if this is it but the local publication and using Transmit has been flawless even with FTP.

1 Like