FTP Upload Error: Failure When Receiving Data From Peer


(Chris Gill) #1

Please provide a few details in the following format so we can help you as quickly as possible!

RapidWeaver Version: 6.2.4 (14923)
System Version: 10.10.4
Hardware: 13-Inch MacBook Pro with Retina Display, 2.7GHz Processor, 128 GB SSD Storage, 8GB Memory.

Issue:
It’s a crapshoot whenever I am publishing using Rapidweaver. I’ll hit the button over and over and I mostly get the error:

“Couldn’t upload to your FTP Server: Failure when receiving data from the peer.”

Every once and a while it works but it is very very frustrating.

Expected Result:
It should publish every time.

Additional Links:
I’m uploading the site to an old domain til I get the bugs worked out.
www.seaminglymodern.com


Uploading website
(Matthias Ficht) #2

Try RapidWeaver 6.3 Beta 2 and see if that changes s.th. …: http://community.realmacsoftware.com/t/rapidweaver-6-3-beta-2/922/4


(Buck) #3

I have this same problem. I’m running RW 6.3.4. You’re right about publishing being a crapshoot. Does anybody know what is causing this, or have a solution?


(Nik Fletcher) #4

Who are you hosting your site with?


(Mark Dewart) #5

I have the same problem uploading to Machighway. The workaround that is somewhat helpful for me is to quit and restart Rapidweaver 6.34. On restart, the file upload goes smoothly everytime.


(Gabrielle Vickery) #6

I’m having the same issue with 6.3.4. Random error messages coming up when I try to publish. Newest one today is also ‘Failure when receiving data from the peer’.


(Gabrielle Vickery) #7

A different one now with the same website: "Couldn’t upload to your FTP server: Login denied.

Although interestingly, sometimes I can refresh the live page and the change has been updated. So Rapidweaver ‘says’ it’s failed, but it hasn’t.


(Nik Fletcher) #8

How many concurrent uploads are set in the RapidWeaver preferences?

—Nik


(Gabrielle Vickery) #9

It says maximum (6).


(Nik Fletcher) #10

Try lowering it (either half-way to 3, or to 1). Does that improve things?

—Nik


(Chris Gill) #11

It took me a while but I was finally able to figure out what the problem was.

Every time I published, Rapidweaver was not signing out my username/password from the server. If I called the host and asked them to clear all the users logged in (which was me from all the past publishing) it would work fine…till I hit the maximum amount of logins by my server again and had to have them clear all the logins again.

I had to move to publishing my files with Filezilla and it works fine.

nikf…any thoughts?

-Sands

P.S. Concurrent uploads didn’t help me at all.


(Nik Fletcher) #12

We’re investigating this; the only time we’ve seen this happen in testing is where the server disconnects a connection during upload…

Thanks for the report!


(Gabrielle Vickery) #13

Changing concurrent uploads didn’t make a difference.

I was browsing through the forums and someone with the same problem got around it by quitting Rapidweaver and going back in and then exporting, so I just tried that and it worked. Wierd or what?


(Willem) #14

Same problem here. Need to QUIT RW and reopen every time I want to upload the 2nd time. Basically got in the habit of not even trying anymore and just restarting RW everytime I want to upload. haha. Thats sometimes 20+ times in an hour to see minor changes etc.

Maybe should make it an automater action to restart rapid weaver before every upload?


#15

@nikf

This is exactly what I’m seeing too. If I log into my cpanel I can see connections lingering around as if RW isn’t closing them properly. No other FTP app has this issue when uploading, only RW.


(Nik Fletcher) #16

Who are you hosting with?

Thanks!

—N


(Bruce Kieffer) #17

I’m having the same problem randomly. BlueHost is my host. Where in my BH cPanel do I go to see if there are “stuck” ftp connections?

UPDATE: I had Fetch open at the same time. I quit that, and so far no more error messages.

UPDATE 2: Fetch is not the problem. I had errors again this morning with Fetch not running.


(Mark Dewart) #18

Restarting Rapidweaver “solves” this recurring FTP Upload Error for me. My sites are hosted on Machighway. I usually have Transmit running concurrently. Will try closing that FTP app to see if it is contributing to the “Failure When Receiving Data From Peer”


(cyclingone) #19

Same problem, happening almost every upload. But then I hit publish again and it goes through okay. Go figure…

El Capitan, Stacks 3, RW 6.3.7

So glad I don’t have to restart RW each time I try to upload (like some), but it’s still a pain to have to do the upload twice (sometime 3 times) in a row each time I make a change to the site. Please find a fix for this. BTW tried lowering max concurrent uploads all the way down to 1, still no good. Using GoDaddy hosting.

Barry
SilkyWebDesign.com


(Julian) #20

I also have been having that problem. Seems that at best RW can upload once or rarely maybe twice before that error pops up. A restart seems to solve it but geese. LoL

Also a new issue started today.

Last night I was uploading a few changes and that error came up. This morning every time I try to upload it just hangs “Publishing your website” for a while then I get the error… "Couldn’t upload to your FTP server. Upload failed (at start/before it took off). I have changed how many concurrent connections from 1 to 6 all to no avail.

Nothing has changed with my FTP connection, Service provider, or website hosting service.

Please help!