Go-CMS Blog vs Content page stack


(martin james) #1

Can someone please explain what a Go-CMS content page does or what you would use it for. I get the blog page but how do you use the content page and what stacks are allow on the same page. Thanks

Marty

All current. 10.4.3, RW 8.1.7, stacks 3.6, go cms 2.01, foundation 1.8.6


(Rob Beattie) #2

Once you’ve set GoCMS up…

You drag a GoCMS stack out onto a Stacks page and publish it.
Go to the page on the Internet, log in and then your GoCMS stack will have a dotted line round it to indicate it’s editable.
It’ll have some Lorem Ipsum text in it as well. You can delete this and add your own text, headers, Markdown, images, image slideshows, Soundcloud tracks and videos from YouTube and Vimeo, all from your web browser. Go has a little pop-up menu bar that lets you choose the kind of content you want to add.

Hope this helps.

Rob


(Yabdab) #3

What @robbeattie said :grin:


(martin james) #4

Hi And thanks for the replies.
I guess I want to know what is the proper and or typical way to use a Go-CMS Content stack. In the Go-CMS stacks package there are 4 stacks the GOCMS GoBase, GoBlog, GoContent and GoLock.
I am assuming that the developer spent considerable time making the extra GoContent stack and I would like to know that would be typically used by an expert wed designer.

On the GoCMS support pages the instructions say you can use a GoBlog stack or GoContent. Maybe that means and or. If there was video, like what @Nickcates made for cartloom, I probably would watch that over and over again instead of asking questions.

I also want to make sure I am not making any mistakes that might throw errors or the dreaded _application-call-back-fail-to-publish-RW-crash-fail-to-produce-logs.

I also need to find out which of my actions might make errors. For example if while testing I make a GoBlog page and then later delete it. Am I in danger of having that content try to update, or re-populate on a new replacement page.

For those who are testing blog entries and then want to delete the test content, how to they start over again?

I am using Foundation with the Foundation theme. All my equipment and software is updated to current (OS 10.14.3 RW8.1.7)

I think that I am not alone with having publishing problems lately, and that it is my understanding that problems multiply. For example 2 days ago I had my host re-direct to https, but then an application callback (probably caused by my fatal error of using a one column stack instead of a one column foundation stack) prevented my source code from matching (http vs https). When trying to figure that out I deleted my GoCMS pages, not understanding that my deletion did not clear the file tree on my server of the prior Go content.

I am just starting out on a newer maybe better FTP program, “Forklift 3” and maybe that will help me get some of these problems straightened out.

Thanks for the help, Marty


(martin james) #5

Thanks Rob. I was trying to figure out why my pages were giving error messages. And i wasn’t sure what a goCMC content stack was for. The blog stack makes since it makes a blog, and think that the content sack is like to put a title above your blog.

I think I might have had a https redirect between when I updated my test blog and when those pages stoped working.

I wonder if it is possible if even though I have gone back and removed from the server via FTP app all the test blog data, and also removed the goCMS pages from my site that I am still getting a domain mismatch because of the GoCMS PHP files that probably still identify the old pre https.

I guess that even after even after 10 years on RW that I am still a beginner.

Maybe one of the support people from RW could help me get off the ground here.

M


(system) #6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.