Google Chrome refuse to open a site (SOLVED)

Good afternoon, this is a non-RW matter, but I come to you for help. I cannot access one of my sites with Google Chrome (This site can’t be reached is unreachable. ERR_ADDRESS_UNREACHABLE). I have already tried the possible fixes (clear history and cache, uninstall and reinstall Chrome, DNS, etc), without success.

There are subdomains that, however, open without problems. (Https:// I would greatly appreciate any help or comments.

I just tried it and it worked ok in Chrome for me on the Mac (Big Sur). Very, very slow to load though. There are some oversized images. Eg. the attached image (downsized as a jpeg) is a nearly 1mb png on the site. Apologies I am on a 1, maybe 2mbps connection :slight_smile:


Thank you very much Greg for your kind response and the warning regarding the image. The strange thing, however, is that it opens without problem in other browsers.


Site works fine on chrome android and on my chromebook.

Thanks for your response. So, do you thing that’s is just a problem on my PowerBook?

I loged as guest on my PowerBook and the site opens. So there is someting wrong somewhere on preferences or system files.
Any ideas?

I did a quick search for that error and most say to turn off your router wait around 1-2 minutes and restart your router. I also saw this mentioned:

Clear Chrome DNS Cache

To fix err address unreachable you should flush Chrome’s DNS cache.

These are the steps to clear Google Chrome’s DNS cache:

  1. Open Google Chrome.
  2. Type chrome://net-internals/#dns in address bar and press enter.
  3. Now click on clear host cache.

Maybe it will solve your issue

Thanks rolisize, I already tried the DNS option, it doesn’t work.
While booting in safe mode allows me to access. But not fix the issue.

I’ll assume that you tried to restart (or even a hard reset) your router. Or have you tried (since it’s a notebook) to login to a different network?

Did you try Incognito mode?

Also might be any chrome extensions you might have installed.

Hi Doug, sorry for my late reply. Yes, I already tried resetting the router, incognito mode, uninstalling extensions, to no avail.

As I mentioned before, login as another user or after safe boot allows access to the page, but the connection fails again when returning to the usual login.

Somehow the site server IP was inadvertently included in a LittleSnitch rule. :hot_face:
Thank you very much for your interest in helping.