Google listing links views incomplete version of site

Just wondering if anyone can help me. My Rapidweaver site is at
The Google rankings for a search for Miracle Street are at the top but all the links load a version of the site that is incomplete with the graphics missing and the navigation as a simple list. Typing www.miraclestreet into the address bar on the browser takes you to the correct version of the site. Any help would be appreciated. Steve

Are theses links to pages that exist with different URL’s?

Hi Doug. No, the URLS are all current. Steve

You have an issue with insecure content being loaded on a secure (https:) site.

Have you set the main site address (URL) correctly with https at the beginning.

The version that looks ok is the non https version. Google has indexed and links to the https version.

1 Like

Listen to this…

Thanks a lot Neil. I did wonder if that might be the issue as the URL now come up as Not Secure after Google made the changes. Really not sure how to fix it to be honest. I did look at Cloudflare as an option of routing the site to make it https compliant but was nervous about playing with the dns settings. Is there an easier way to sort this?

It looks like your site does have an SSL certificate installed, it’s just not showing because your site is loading content from the non https version.

Don’t waste your time with Cloudflare, it’s junk.

Can you post a screenshot of your general RW settings and your publishing settings?

Hi Neil, interested to know why you think cloudflare is junk?

I’ve personally tried it twice. Both times had a negative effect on page loading times. The TTFB (Time To First Byte) decreases also.

I realise that speed is of less importance to those selling “features”. In my opinion, performance should be a feature of high priority.

Apart from using RW to client sites, I use WordPress just as much. On the (private) Wordpress forum I use regularly, many users did a test to see how “optimised” they could get their site/s. Out of all the tests conducted using many variants of CDNs, caching, no caching, no CDN etc. Cloudflare was, by far, the worst performer in every single test.

I :heart: Cloudflare

I don’t want to derail this topic though… @miraclestreet have a listen to that podcast episode. Greg and I really review all of the ins and outs of getting https on your site.

He already has an SSL. Have you not read this thread or looked at his site at all?

I see that. But there is a lot more to it than just getting an SSL certificate. We also talk about all of the things that you need to do to move your site to use https. Have you listened to the episode?

Is that it Neil?

Just realised the web address on the settings was still http so I changed it to https and re-uploaded the site and it looks like its fixed. Its that all there is to it??

Great! That’s working.

All you need to do now is make sure the http version is automatically redirected to to the https version. You don’t want both versions available because you always want users to use the secure version.

You’ll need to add a bit of code to that .htaccess file on your web host. Do you have access to that?

Yep I have access to the host (Easyspace) what do I need to do? Cheers Neil. Steve

Are you using RW8?

Yes RW8

In the publishing settings, you can click “Edit .htaccess File”. This will first check to see if there is an existing .htaccess file. If not, you can create one.

I need to know if there’s an existing .htaccess file on server? And, if there is, what are the contents?

If there isn’t an existing .htaccess file, create on and add the code below to it. Be very careful with the .htaccess file. It’s very powerful and can break your site if used incorrectly.

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
RewriteCond %{HTTP_HOST} !^www\. [NC]
RewriteRule .* https://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]